cppcheck: Bump to 2.11.1

This commit is contained in:
Tee KOBAYASHI 2023-07-01 10:05:54 +09:00 committed by xtkoba
parent 6c04f06192
commit c31c13f8a6
2 changed files with 8 additions and 16 deletions

View File

@ -2,9 +2,15 @@ TERMUX_PKG_HOMEPAGE=https://github.com/danmar/cppcheck
TERMUX_PKG_DESCRIPTION="tool for static C/C++ code analysis"
TERMUX_PKG_LICENSE="GPL-3.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=2.10.3
TERMUX_PKG_VERSION=2.11.1
TERMUX_PKG_AUTO_UPDATE=true
TERMUX_PKG_UPDATE_METHOD=repology # Upstream only releases major versions theough GitHub. Other minor updates are released using git tags, better rely on repology for updated versiom
TERMUX_PKG_SRCURL=https://github.com/danmar/cppcheck/archive/$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_SHA256=8aae5e116daeaaf5d19f3efa61b91c06f161cb97412a1d1af6e1e20686e48967
TERMUX_PKG_SHA256=fef6ef868d562d49136f158e1d0f7a38237e7e1c0a91d9189bdd465f1fe54316
TERMUX_PKG_DEPENDS="libc++"
# Prevent running dmake during builds. dmake just generates Makefile which we
# aren't using, and QT translation files, but as we are not building the GUI,
# there is no need. And anyways will lead to "Exec format" error as running
# target binaries on host
TERMUX_PKG_EXTRA_CONFIGURE_ARGS+=" -DDISABLE_DMAKE=ON"

View File

@ -1,14 +0,0 @@
Prevent running dmake during builds. dmake just generates Makefile which we aren't using, and QT translation files, but as we are not building the GUI, there is no need.
And anyways will lead to "Exec format" error as running target binaries on host
--- ./cli/CMakeLists.txt.orig 2022-05-22 12:43:53.588222173 +0530
+++ ./cli/CMakeLists.txt 2022-05-22 12:44:16.178222164 +0530
@@ -45,7 +45,6 @@
add_dependencies(cppcheck copy_cfg)
add_dependencies(cppcheck copy_addons)
add_dependencies(cppcheck copy_platforms)
-add_dependencies(cppcheck run-dmake)
install(TARGETS cppcheck
RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR}