graphviz: link libgvc against libandroid-glob

This commit is contained in:
Tom Yan 2022-08-09 18:57:26 +08:00 committed by tomty89
parent 7fe46ac80c
commit cb5c48f81d
2 changed files with 19 additions and 3 deletions

View File

@ -1,6 +1,8 @@
--- ./CMakeLists.txt.orig 2021-12-08 16:43:22.784370693 +0530
+++ ./CMakeLists.txt 2021-12-08 16:44:08.814370676 +0530
@@ -118,9 +118,7 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 025052b..59bc17d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -118,9 +118,7 @@ if(with_zlib)
find_package(ZLIB)
endif()
@ -11,3 +13,16 @@
if(WIN32)
# Find Windows specific dependencies
diff --git a/lib/gvc/CMakeLists.txt b/lib/gvc/CMakeLists.txt
index decab25..737a6fa 100644
--- a/lib/gvc/CMakeLists.txt
+++ b/lib/gvc/CMakeLists.txt
@@ -76,6 +76,8 @@ if(ZLIB_FOUND)
target_link_libraries(gvc PUBLIC ${ZLIB_LIBRARIES})
endif()
+target_link_libraries(gvc PUBLIC -landroid-glob)
+
if(${with_ortho})
target_link_libraries(gvc PRIVATE
$<TARGET_OBJECTS:ortho_obj>

View File

@ -3,6 +3,7 @@ TERMUX_PKG_DESCRIPTION="Rich set of graph drawing tools"
TERMUX_PKG_LICENSE="EPL-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=2.50.0
TERMUX_PKG_REVISION=1
TERMUX_PKG_SRCURL=https://gitlab.com/graphviz/graphviz/-/archive/$TERMUX_PKG_VERSION/graphviz-$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_SHA256=afa48581f764a35e148909cc96a0308ec2356b5225b64af12492f3392f20ef1c
TERMUX_PKG_DEPENDS="libandroid-glob, libc++, libcairo, pango, libexpat, libltdl, librsvg, libgd, zlib"