tree-wide: Cleanup lib{pthread,rt} patches

not handled in commit 986babfda7.

%ci:no-build
This commit is contained in:
Tee KOBAYASHI 2023-02-13 15:58:17 +09:00 committed by xtkoba
parent f65eb6c69d
commit cec1d690cf
30 changed files with 6 additions and 332 deletions

View File

@ -1,19 +0,0 @@
--- a/vendor/CMakeLists.mke2fs.txt 2022-10-27 01:17:32.706970654 +0530
+++ b/vendor/CMakeLists.mke2fs.txt 2022-10-27 01:18:27.256970633 +0530
@@ -135,7 +135,7 @@ endif(HAVE_SYS_TYPES_H)
target_link_libraries(e2fsdroid
libext2fs libsparse libzip libcutils liblog libutil
- libbase libselinux libsepol z PkgConfig::libpcre2-8 pthread)
+ libbase libselinux libsepol z PkgConfig::libpcre2-8)
target_include_directories(e2fsdroid PRIVATE
e2fsprogs/lib e2fsprogs/lib/ext2fs selinux/libselinux/include
core/libcutils/include e2fsprogs/misc)
@@ -142,6 +142,6 @@
e2fsprogs/contrib/android/ext2simg.c)
target_link_libraries(ext2simg
- libext2fs libsparse libbase libzip liblog libutil z pthread)
+ libext2fs libsparse libbase libzip liblog libutil z)
target_include_directories(ext2simg PRIVATE
e2fsprogs/lib core/libsparse/include)

View File

@ -28,7 +28,3 @@ termux_step_configure() {
python3 $TERMUX_PKG_SRCDIR/configure.py \
$TERMUX_PKG_EXTRA_CONFIGURE_ARGS
}
termux_step_post_configure() {
sed -i '/^LIB_LINKS_TO\s*=/s/\s-lrt//' Makefile
}

View File

@ -1,7 +1,7 @@
diff -uNr cava-0.8.3/Makefile.am cava-0.8.3.mod/Makefile.am
--- cava-0.8.3/Makefile.am 2022-11-04 16:01:05.000000000 +0800
+++ cava-0.8.3.mod/Makefile.am 2022-11-05 16:58:02.059784566 +0800
@@ -8,13 +8,13 @@
@@ -8,7 +8,7 @@
cava_CPPFLAGS = -DPACKAGE=\"$(PACKAGE)\" -DVERSION=\"$(VERSION)\" \
-D_POSIX_SOURCE -D_POSIX_C_SOURCE=200809L -D_XOPEN_SOURCE_EXTENDED \
-DFONTDIR=\"@FONT_DIR@\"
@ -10,10 +10,3 @@ diff -uNr cava-0.8.3/Makefile.am cava-0.8.3.mod/Makefile.am
if OSX
cava_CFLAGS += -DNORT
cava_LDADD =
else
- cava_LDADD = -lrt
+ cava_LDADD =
cava_font_dir = @FONT_DIR@
cava_font__DATA = cava.psf
endif

View File

@ -1,5 +1,5 @@
Set uname_S to Linux instead of detecting build machine.
Android does not support -lrt.
Android before API 26 does not support sync_file_range.
diff -uNr ../git-2.36.0/config.mak.uname ./config.mak.uname
--- ../git-2.36.0/config.mak.uname 2022-04-18 02:52:38.000000000 -0300
@ -13,12 +13,10 @@ diff -uNr ../git-2.36.0/config.mak.uname ./config.mak.uname
uname_M := $(shell sh -c 'uname -m 2>/dev/null || echo not')
uname_O := $(shell sh -c 'uname -o 2>/dev/null || echo not')
uname_R := $(shell sh -c 'uname -r 2>/dev/null || echo not')
@@ -55,9 +55,6 @@
HAVE_DEV_TTY = YesPlease
HAVE_CLOCK_GETTIME = YesPlease
@@ -57,7 +57,6 @@
HAVE_CLOCK_MONOTONIC = YesPlease
- # -lrt is needed for clock_gettime on glibc <= 2.16
- NEEDS_LIBRT = YesPlease
# -lrt is needed for clock_gettime on glibc <= 2.16
NEEDS_LIBRT = YesPlease
- HAVE_SYNC_FILE_RANGE = YesPlease
HAVE_GETDELIM = YesPlease
FREAD_READS_DIRECTORIES = UnfortunatelyYes

View File

@ -1,13 +0,0 @@
diff --git a/src/cadet/Makefile.am b/src/cadet/Makefile.am
index d8d81bf..cfc182b 100644
--- a/src/cadet/Makefile.am
+++ b/src/cadet/Makefile.am
@@ -72,7 +72,7 @@ gnunet_service_cadet_LDADD = \
$(top_builddir)/src/hello/libgnunethello.la \
$(top_builddir)/src/block/libgnunetblock.la
if LINUX
- gnunet_service_cadet_LDFLAGS = -lrt \
+ gnunet_service_cadet_LDFLAGS = \
$(GN_LIBINTL)
endif

View File

@ -1,12 +0,0 @@
diff -uNr k2pdfopt_v2.53/CMakeLists.txt k2pdfopt_v2.53.mod/CMakeLists.txt
--- k2pdfopt_v2.53/CMakeLists.txt 2020-06-01 01:34:34.000000000 +0300
+++ k2pdfopt_v2.53.mod/CMakeLists.txt 2022-07-02 18:19:48.605603955 +0300
@@ -128,7 +128,7 @@
# ms
add_executable(k2pdfopt k2pdfopt.c)
-target_link_libraries (k2pdfopt k2pdfoptlib willuslib ${K2PDFOPT_LIB} pthread)
+target_link_libraries (k2pdfopt k2pdfoptlib willuslib ${K2PDFOPT_LIB})
message("")

View File

@ -6,7 +6,7 @@
# ms
-add_executable(k2pdfopt k2pdfopt.c)
+add_executable(k2pdfopt k2pdfopt.c misc.c)
target_link_libraries (k2pdfopt k2pdfoptlib willuslib ${K2PDFOPT_LIB})
target_link_libraries (k2pdfopt k2pdfoptlib willuslib ${K2PDFOPT_LIB} pthread)
install(TARGETS k2pdfopt RUNTIME DESTINATION bin)
--- a/misc.c

View File

@ -9,6 +9,5 @@ TERMUX_PKG_BUILD_DEPENDS="boost, boost-headers, openssl"
TERMUX_PKG_PLATFORM_INDEPENDENT=true
termux_step_pre_configure() {
sed --in-place -e 's/-lrt//' configure.ac
autoreconf -fi
}

View File

@ -1,18 +0,0 @@
diff -uNr a/bench/CMakeLists.txt b/bench/CMakeLists.txt
--- a/bench/CMakeLists.txt
+++ b/bench/CMakeLists.txt
@@ -4,12 +4,12 @@
# targets
add_executable(bench ${SOURCES})
-if(UNIX AND NOT APPLE AND NOT HAIKU)
+if(UNIX AND NOT APPLE AND NOT HAIKU AND NOT ANDROID)
# cmake is complaining about LINK_PRIVATE in original PR
# and removing it does not seem to hurt, so be it.
# target_link_libraries(bench LINK_PRIVATE rt)
target_link_libraries(bench rt)
-endif(UNIX AND NOT APPLE AND NOT HAIKU)
+endif(UNIX AND NOT APPLE AND NOT HAIKU AND NOT ANDROID)
target_link_libraries(bench blosc_shared)
# have to copy blosc dlls on Windows

View File

@ -1,12 +0,0 @@
diff -u -r ../grpc-1.8.3/Makefile ./Makefile
--- ../grpc-1.8.3/Makefile 2017-12-31 20:38:59.000000000 +0000
+++ ./Makefile 2018-01-13 00:48:23.449627239 +0000
@@ -369,7 +369,7 @@
endif
ifeq ($(SYSTEM),Linux)
-LIBS = dl rt m pthread
+LIBS = dl m
LDFLAGS += -pthread
endif

View File

@ -11,18 +11,6 @@ index a407271b4..6ecfda3ee 100755
list(FIND X86_ALIASES "${SYSPROC}" X86MATCH)
list(FIND ARM_ALIASES "${SYSPROC}" ARMMATCH)
set(POWER_ALIASES ppc64 ppc64le)
@@ -85,7 +85,10 @@ else()
endif()
if(UNIX)
- list(APPEND PLATFORM_LIBS pthread)
+ find_library(LIBPTHREAD pthread)
+ if(LIBPTHREAD)
+ list(APPEND PLATFORM_LIBS pthread)
+ endif()
find_library(LIBRT rt)
if(LIBRT)
list(APPEND PLATFORM_LIBS rt)
@@ -246,18 +249,8 @@ if(GCC)
endif()
message(STATUS "cross compile arm")

View File

@ -39,15 +39,6 @@
# --- manual settings from configure.local -----------------------------
@@ -310,7 +307,7 @@
runtest isblank ISBLANK || true
runtest mkdtemp MKDTEMP || true
runtest mkstemps MKSTEMPS || true
-runtest nanosleep NANOSLEEP "${LD_NANOSLEEP}" "-lrt" || true
+runtest nanosleep NANOSLEEP "${LD_NANOSLEEP}" "" || true
runtest ntohl NTOHL || true
runtest O_DIRECTORY O_DIRECTORY || true
runtest PATH_MAX PATH_MAX || true
@@ -458,7 +455,7 @@
[ ${HAVE_GETLINE} -eq 0 ] && echo "#include <stdio.h>"

View File

@ -1,12 +0,0 @@
diff -uNr nim-1.6.0/makefile nim-1.6.0.mod/makefile
--- nim-1.6.0/makefile 2021-10-19 01:39:26.000000000 +0100
+++ nim-1.6.0.mod/makefile 2021-11-28 08:52:56.003610701 +0100
@@ -23,7 +23,7 @@
ifeq ($(uos),linux)
myos = linux
- LDFLAGS += -ldl -lm -lrt
+ LDFLAGS += -ldl -lm
endif
ifeq ($(uos),dragonfly)
myos = freebsd

View File

@ -1,10 +0,0 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -56,7 +56,6 @@
)
set (OB_LINK_LIBRARIES
${OB_LINK_LIBRARIES}
- pthread
icuuc
icui18n
)

View File

@ -1,17 +1,5 @@
--- ../CMakeLists.txt.orig 2022-02-04 15:41:06.250332497 +0000
+++ ./CMakeLists.txt 2022-02-04 16:24:58.062366747 +0000
@@ -38,9 +38,9 @@
endif(WIN32)
add_subdirectory(csrc)
-if(NOT WIN32 AND NOT APPLE)
+if(NOT WIN32 AND NOT APPLE AND NOT ANDROID)
link_libraries(rt pthread)
-endif(NOT WIN32 AND NOT APPLE)
+endif(NOT WIN32 AND NOT APPLE AND NOT ANDROID)
option(UNISTD "Enable libunistd" false)
if(UNISTD)
@@ -61,7 +61,6 @@
add_custom_command(OUTPUT ${PFORTH_DIC}
COMMAND ./pforth -i system.fth

View File

@ -1,11 +0,0 @@
--- a/src/bc/configure
+++ b/src/bc/configure
@@ -5029,7 +5029,7 @@
fi
;;
linux*|gnu*)
- LIBS="$LIBS -ldl -lm -lrt -rdynamic"
+ LIBS="$LIBS -ldl -lm -rdynamic"
DYN_CFLAGS="-fPIC"
curses_portable_link="/usr/lib/${host_cpu}-${host_os}/libncurses.a /usr/lib/${host_cpu}-${host_os}/libtermcap.a"
case "$host_cpu" in

View File

@ -1,12 +0,0 @@
diff -u -r ../redis-5.0.0/src/Makefile ./src/Makefile
--- ../redis-5.0.0/src/Makefile 2018-10-17 15:31:39.000000000 +0000
+++ ./src/Makefile 2018-10-18 17:20:36.811751940 +0000
@@ -100,7 +100,7 @@
else
# All the other OSes (notably Linux)
FINAL_LDFLAGS+= -rdynamic
- FINAL_LIBS+=-ldl -pthread -lrt
+ FINAL_LIBS+=-ldl
endif
endif
endif

View File

@ -1,11 +0,0 @@
diff -uNr tesseract-5.2.0/CMakeLists.txt tesseract-5.2.0.mod/CMakeLists.txt
--- tesseract-5.2.0/CMakeLists.txt 2022-07-07 05:15:49.000000000 +0900
+++ tesseract-5.2.0.mod/CMakeLists.txt 2022-09-30 13:12:18.222593892 +0900
@@ -859,7 +859,7 @@
target_link_libraries(tesseract ${TIFF_LIBRARIES})
endif()
-if(OPENMP_BUILD AND UNIX)
+if(OPENMP_BUILD AND UNIX AND NOT ANDROID)
target_link_libraries(tesseract pthread)
endif()

View File

@ -1,13 +0,0 @@
diff -u -r ../toxic-0.8.3/Makefile ./Makefile
--- ../toxic-0.8.3/Makefile 2018-10-30 22:03:44.000000000 +0000
+++ ./Makefile 2018-11-01 02:21:19.464155263 +0000
@@ -20,9 +20,6 @@
# Check on wich system we are running
UNAME_S = $(shell uname -s)
-ifeq ($(UNAME_S), Linux)
-LDFLAGS += -ldl -lrt
-endif
ifeq ($(UNAME_S), OpenBSD)
LIBS := $(filter-out ncursesw, $(LIBS))
LDFLAGS += -lncursesw

View File

@ -1,10 +0,0 @@
+++ ./Makefile 2019-08-26 04:27:09.354957504 +0300
@@ -53,7 +53,7 @@
COMMON_CFLAGS := -D_GNU_SOURCE $(CFLAGS) $(CPPFLAGS)
COMMON_CFLAGS += -iquote $(srcdir) -iquote $(objdir) -iquote $(srcdir)/arch/$(ARCH)
#CFLAGS-DEBUG = -g -D_GNU_SOURCE $(CFLAGS_$@)
-COMMON_LDFLAGS := -lrt -ldl -pthread -Wl,-z,noexecstack $(LDFLAGS)
+COMMON_LDFLAGS := -ldl -pthread -Wl,-z,noexecstack $(LDFLAGS)
ifneq ($(elfdir),)
COMMON_CFLAGS += -I$(elfdir)/include
COMMON_LDFLAGS += -L$(elfdir)/lib

View File

@ -1,11 +0,0 @@
--- a/cli/CMakeLists.txt
+++ b/cli/CMakeLists.txt
@@ -76,7 +76,7 @@
# Link to the vgmstream library as well as libao
target_link_libraries(vgmstream123
libvgmstream
- ao pthread dl)
+ ao dl)
setup_target(vgmstream123 TRUE)

View File

@ -9,14 +9,6 @@
ENABLE_GLOB := 1
ENABLE_PLUGINS := 1
ENABLE_READLINE := 1
@@ -138,7 +138,6 @@
else
LDFLAGS += -rdynamic
ifneq ($(OS), OpenBSD)
-LDLIBS += -lrt
endif
endif
@@ -216,9 +215,8 @@
endif

View File

@ -9,12 +9,6 @@ TERMUX_PKG_SHA256=e304b253236a279f10b133fdd19f366f271581ebf12647cea84667fcfada1f
TERMUX_PKG_DEPENDS="libssh2, libxml2, openssl, readline"
termux_step_pre_configure() {
local f
for f in netconf/src/*/Makefile.am; do
sed -i '/_la_LDFLAGS = /s/ -lrt$//' ${f}
sed -i '/_la_LDFLAGS = /s/ -lrt / /' ${f}
done
autoreconf -fi
CPPFLAGS+=" -D__USE_BSD"

View File

@ -15,20 +15,3 @@ index cb66def..e70d74b 100644
PKG_CONFIG ?= pkg-config
CFLAGS += $(EXTRA_CFLAGS)
@@ -147,16 +147,6 @@ endif
OBJS += ../src/utils/$(CONFIG_ELOOP).o
OBJS_c += ../src/utils/$(CONFIG_ELOOP).o
-ifndef CONFIG_OSX
-ifeq ($(CONFIG_ELOOP), eloop)
-# Using glibc < 2.17 requires -lrt for clock_gettime()
-# OS X has an alternate implementation
-LIBS += -lrt
-LIBS_c += -lrt
-LIBS_p += -lrt
-endif
-endif
-
ifdef CONFIG_ELOOP_POLL
CFLAGS += -DCONFIG_ELOOP_POLL
endif

View File

@ -23,12 +23,3 @@ diff -Naur dunst-1.8.1/config.mk dunst-1.8.1.mod/config.mk
ifneq (0, ${WAYLAND})
ENABLE_WAYLAND= -DENABLE_WAYLAND
@@ -37,7 +37,7 @@
# flags
DEFAULT_CPPFLAGS = -Wno-gnu-zero-variadic-macro-arguments -D_DEFAULT_SOURCE -DVERSION=\"${VERSION}\" -DSYSCONFDIR=\"${SYSCONFDIR}\"
DEFAULT_CFLAGS = -g -std=gnu99 -pedantic -Wall -Wno-overlength-strings -Os ${ENABLE_WAYLAND} ${EXTRA_CFLAGS}
-DEFAULT_LDFLAGS = -lm -lrt
+DEFAULT_LDFLAGS = -lm
CPPFLAGS_DEBUG := -DDEBUG_BUILD
CFLAGS_DEBUG := -O0

View File

@ -1,31 +0,0 @@
--- src/src/plugins/sensors/dummy/dummy.pro 2020-10-15 06:53:19.000000000 +0000
+++ src.mod/src/plugins/sensors/dummy/dummy.pro 2021-05-14 14:22:51.194482639 +0000
@@ -12,8 +12,6 @@
OTHER_FILES = plugin.json
-unix:!darwin:!qnx:!android:!openbsd: LIBS += -lrt
-
PLUGIN_TYPE = sensors
PLUGIN_CLASS_NAME = dummySensorPlugin
load(qt_plugin)
--- src/src/plugins/sensors/linux/linux.pro 2020-10-15 06:53:19.000000000 +0000
+++ src.mod/src/plugins/sensors/linux/linux.pro 2021-05-14 14:22:09.604788205 +0000
@@ -3,7 +3,6 @@
OTHER_FILES = plugin.json
-!android:LIBS += -lrt
HEADERS += linuxsysaccelerometer.h
SOURCES += linuxsysaccelerometer.cpp \
main.cpp
--- src/src/plugins/sensors/iio-sensor-proxy/iio-sensor-proxy.pro 2020-10-15 06:53:19.000000000 +0000
+++ src.mod/src/plugins/sensors/iio-sensor-proxy/iio-sensor-proxy.pro 2021-05-14 14:28:09.397847029 +0000
@@ -5,7 +5,6 @@
PLUGIN_CLASS_NAME = IIOSensorProxySensorPlugin
load(qt_plugin)
-!android:LIBS += -lrt
HEADERS += iiosensorproxysensorbase.h \
iiosensorproxylightsensor.h \
iiosensorproxyorientationsensor.h \

View File

@ -16,12 +16,3 @@ diff -uNr st-0.8.2/config.mk st-0.8.2.mod/config.mk
PKG_CONFIG = pkg-config
@@ -16,7 +16,7 @@
INCS = -I$(X11INC) \
`$(PKG_CONFIG) --cflags fontconfig` \
`$(PKG_CONFIG) --cflags freetype2`
-LIBS = -L$(X11LIB) -lm -lrt -lX11 -lutil -lXft \
+LIBS = -L$(X11LIB) -lm -lX11 -lXft \
`$(PKG_CONFIG) --libs fontconfig` \
`$(PKG_CONFIG) --libs freetype2`

View File

@ -1,11 +0,0 @@
--- a/common/os/CMakeLists.txt
+++ b/common/os/CMakeLists.txt
@@ -6,7 +6,7 @@
w32tiger.c
os.cxx)
-if(UNIX)
+if(UNIX AND NOT ANDROID)
target_link_libraries(os pthread)
endif()

View File

@ -1,12 +0,0 @@
diff -uNr tigervnc-1.9.0/common/os/CMakeLists.txt tigervnc-1.9.0.mod/common/os/CMakeLists.txt
--- tigervnc-1.9.0/common/os/CMakeLists.txt 2018-07-16 17:08:55.000000000 +0300
+++ tigervnc-1.9.0.mod/common/os/CMakeLists.txt 2018-09-12 11:14:21.776323226 +0300
@@ -6,7 +6,7 @@
w32tiger.c
os.cxx)
-if(UNIX)
+if(UNIX AND NOT ${CMAKE_SYSTEM_NAME} MATCHES "Android")
target_link_libraries(os pthread)
endif()

View File

@ -1,12 +0,0 @@
diff -uNr xdotool-3.20211022.1/platform.sh xdotool-3.20211022.1.mod/platform.sh
--- xdotool-3.20211022.1/platform.sh 2020-02-07 14:32:33.000000000 +0900
+++ xdotool-3.20211022.1.mod/platform.sh 2022-10-21 01:20:46.071532396 +0900
@@ -39,7 +39,7 @@
extralibs() {
case $uname in
- Linux|GNU/kFreeBSD|GNU) echo "-lrt" ;;
+ Linux|GNU/kFreeBSD|GNU) echo "" ;;
esac
}