new package: svt-av1

This commit is contained in:
Tee KOBAYASHI 2023-01-03 09:06:24 +09:00 committed by xtkoba
parent ae642a2919
commit cff57d33ec
3 changed files with 70 additions and 0 deletions

View File

@ -0,0 +1,11 @@
--- a/Source/Lib/Common/Codec/EbThreads.h
+++ b/Source/Lib/Common/Codec/EbThreads.h
@@ -78,7 +78,7 @@
#endif
#include <sched.h>
#include <pthread.h>
-#if defined(__linux__)
+#if defined(__linux__) && !defined(__ANDROID__)
#define EB_CREATE_THREAD(pointer, thread_function, thread_context) \
do { \
pointer = svt_create_thread(thread_function, thread_context); \

17
packages/svt-av1/build.sh Normal file
View File

@ -0,0 +1,17 @@
TERMUX_PKG_HOMEPAGE=https://gitlab.com/AOMediaCodec/SVT-AV1
TERMUX_PKG_DESCRIPTION="Scalable Video Technology for AV1 (SVT-AV1 Encoder and Decoder)"
TERMUX_PKG_LICENSE="custom"
TERMUX_PKG_LICENSE_FILE="LICENSE.md, PATENTS.md"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1.1.0
TERMUX_PKG_SRCURL=https://gitlab.com/AOMediaCodec/SVT-AV1/-/archive/v${TERMUX_PKG_VERSION}/SVT-AV1-v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=1c211b944ac83ef013fe91aee96c01289da4e3762c1e2f265449f3a964f8e4bc
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
-DBUILD_TESTING=OFF
-DCMAKE_OUTPUT_DIRECTORY=$TERMUX_PKG_BUILDDIR
-DCOMPILE_C_ONLY=ON
"
termux_step_pre_configure() {
LDFLAGS+=" -lm"
}

View File

@ -0,0 +1,42 @@
--- a/Source/App/DecApp/CMakeLists.txt
+++ b/Source/App/DecApp/CMakeLists.txt
@@ -30,7 +30,6 @@
if(UNIX)
target_link_libraries(SvtAv1DecApp
- pthread
m)
endif()
--- a/Source/App/EncApp/CMakeLists.txt
+++ b/Source/App/EncApp/CMakeLists.txt
@@ -33,7 +33,6 @@
SvtAv1Enc)
if(UNIX)
target_link_libraries(SvtAv1EncApp
- pthread
m)
endif()
--- a/Source/Lib/Decoder/CMakeLists.txt
+++ b/Source/Lib/Decoder/CMakeLists.txt
@@ -24,7 +24,7 @@
endif()
list(APPEND PLATFORM_LIBS Threads::Threads)
endif()
- set(LIBS_PRIVATE "-lpthread -lm")
+ set(LIBS_PRIVATE "-lm")
endif()
if(COVERAGE)
--- a/Source/Lib/Encoder/CMakeLists.txt
+++ b/Source/Lib/Encoder/CMakeLists.txt
@@ -25,7 +25,7 @@
endif()
list(APPEND PLATFORM_LIBS Threads::Threads)
endif()
- set(LIBS_PRIVATE "-lpthread -lm")
+ set(LIBS_PRIVATE "-lm")
endif()
if(COVERAGE)