{,lib}protobuf: Revbump revdeps to rebuild

This commit is contained in:
Tee KOBAYASHI 2023-02-17 23:17:48 +09:00 committed by xtkoba
parent ae0a376f59
commit d4382a6b81
18 changed files with 236 additions and 13 deletions

View File

@ -1,3 +1,3 @@
TERMUX_SUBPKG_INCLUDE="bin/aapt2"
TERMUX_SUBPKG_DESCRIPTION="AAPT2 (Android Asset Packaging Tool)"
TERMUX_SUBPKG_DEPENDS="libprotobuf"
TERMUX_SUBPKG_DEPENDS="abseil-cpp, libprotobuf"

View File

@ -5,7 +5,7 @@ TERMUX_PKG_MAINTAINER="@termux"
_TAG_VERSION=13.0.0
_TAG_REVISION=6
TERMUX_PKG_VERSION=${_TAG_VERSION}.${_TAG_REVISION}
TERMUX_PKG_REVISION=1
TERMUX_PKG_REVISION=2
TERMUX_PKG_SRCURL=(https://android.googlesource.com/platform/frameworks/base
https://android.googlesource.com/platform/system/core
https://android.googlesource.com/platform/system/libbase
@ -69,6 +69,7 @@ termux_step_pre_configure() {
CFLAGS+=" -fPIC"
CXXFLAGS+=" -fPIC -std=c++17"
CPPFLAGS+=" -DNDEBUG -D__ANDROID_SDK_VERSION__=__ANDROID_API__"
CPPFLAGS+=" -DPROTOBUF_USE_DLLS"
_TMP_LIBDIR=$TERMUX_PKG_SRCDIR/_lib
rm -rf $_TMP_LIBDIR
@ -190,6 +191,7 @@ termux_step_make() {
-lexpat \
-lpng \
-lprotobuf \
$($TERMUX_SCRIPTDIR/packages/libprotobuf/interface_link_libraries.sh) \
-o $_TMP_BINDIR/aapt2
# Build zipalign:

View File

@ -4,13 +4,16 @@ TERMUX_PKG_LICENSE="Apache-2.0, BSD 2-Clause"
TERMUX_PKG_LICENSE_FILE="LICENSE, vendor/core/fastboot/LICENSE"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=33.0.3p2
TERMUX_PKG_REVISION=1
TERMUX_PKG_SRCURL=https://github.com/nmeum/android-tools/releases/download/$TERMUX_PKG_VERSION/android-tools-$TERMUX_PKG_VERSION.tar.xz
TERMUX_PKG_SHA256=6bf6b52d7389e79fc92b63cc206451ee42fc4f7da769d76922193e98d75f5604
TERMUX_PKG_AUTO_UPDATE=true
TERMUX_PKG_DEPENDS="brotli, libc++, liblz4, libprotobuf, libusb, pcre2, zlib, zstd"
TERMUX_PKG_DEPENDS="abseil-cpp, brotli, libc++, liblz4, libprotobuf, libusb, pcre2, zlib, zstd"
TERMUX_PKG_BUILD_DEPENDS="googletest"
termux_step_pre_configure() {
termux_setup_protobuf
termux_setup_golang
LDFLAGS+=" $($TERMUX_SCRIPTDIR/packages/libprotobuf/interface_link_libraries.sh)"
}

View File

@ -0,0 +1,26 @@
--- a/vendor/extras/libjsonpb/parse/jsonpb.cpp
+++ b/vendor/extras/libjsonpb/parse/jsonpb.cpp
@@ -50,8 +50,10 @@
if (!status.ok()) {
#if GOOGLE_PROTOBUF_VERSION < 3016000
return MakeError<std::string>(status.error_message().as_string());
-#else
+#elif GOOGLE_PROTOBUF_VERSION < 4022000
return MakeError<std::string>(status.message().as_string());
+#else
+ return MakeError<std::string>(status.ToString());
#endif
}
return ErrorOr<std::string>(std::move(json));
@@ -67,8 +69,10 @@
if (!status.ok()) {
#if GOOGLE_PROTOBUF_VERSION < 3016000
return MakeError<std::monostate>(status.error_message().as_string());
-#else
+#elif GOOGLE_PROTOBUF_VERSION < 4022000
return MakeError<std::monostate>(status.message().as_string());
+#else
+ return MakeError<std::monostate>(status.ToString());
#endif
}
if (!message->ParseFromString(binary)) {

View File

@ -3,6 +3,7 @@ TERMUX_PKG_DESCRIPTION="A remote shell that automatically reconnects without int
TERMUX_PKG_LICENSE="Apache-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION="6.2.4"
TERMUX_PKG_REVISION=1
TERMUX_PKG_SRCURL=git+https://github.com/MisterTea/EternalTerminal
TERMUX_PKG_GIT_BRANCH=et-v${TERMUX_PKG_VERSION}
TERMUX_PKG_AUTO_UPDATE=true

View File

@ -4,7 +4,8 @@ TERMUX_PKG_LICENSE="Apache-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_SRCURL=git+https://github.com/grpc/grpc
TERMUX_PKG_VERSION=1.52.0
TERMUX_PKG_DEPENDS="c-ares, ca-certificates, libc++, libprotobuf, libre2, openssl, protobuf, zlib"
TERMUX_PKG_REVISION=1
TERMUX_PKG_DEPENDS="abseil-cpp, c-ares, ca-certificates, libc++, libprotobuf, libre2, openssl, protobuf, zlib"
TERMUX_PKG_BREAKS="libgrpc-dev"
TERMUX_PKG_REPLACES="libgrpc-dev"
TERMUX_PKG_BUILD_DEPENDS="gflags, gflags-static"
@ -13,6 +14,7 @@ TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
-DCMAKE_STRIP=$(command -v strip)
-DGIT_EXECUTABLE=$(command -v git)
-DBUILD_SHARED_LIBS=ON
-DgRPC_ABSL_PROVIDER=package
-DgRPC_CARES_PROVIDER=package
-DgRPC_PROTOBUF_PROVIDER=package
-DgRPC_SSL_PROVIDER=package
@ -50,4 +52,7 @@ termux_step_pre_configure() {
export PATH=$TERMUX_PKG_HOSTBUILD_DIR:$PATH
export GRPC_CROSS_COMPILE=true
CPPFLAGS+=" -DPROTOBUF_USE_DLLS"
LDFLAGS+=" $($TERMUX_SCRIPTDIR/packages/libprotobuf/interface_link_libraries.sh)"
}

View File

@ -0,0 +1,58 @@
--- a/include/grpcpp/impl/codegen/config_protobuf.h
+++ b/include/grpcpp/impl/codegen/config_protobuf.h
@@ -69,7 +69,7 @@
#include <google/protobuf/util/json_util.h>
#include <google/protobuf/util/type_resolver_util.h>
#define GRPC_CUSTOM_JSONUTIL ::google::protobuf::util
-#define GRPC_CUSTOM_UTIL_STATUS ::google::protobuf::util::Status
+#define GRPC_CUSTOM_UTIL_STATUS ::absl::Status
#endif
namespace grpc {
--- a/src/compiler/config_protobuf.h
+++ b/src/compiler/config_protobuf.h
@@ -50,7 +50,7 @@
#endif
#ifndef GRPC_CUSTOM_CSHARP_GETCLASSNAME
-#include <google/protobuf/compiler/csharp/csharp_names.h>
+#include <google/protobuf/compiler/csharp/names.h>
#define GRPC_CUSTOM_CSHARP_GETCLASSNAME \
::google::protobuf::compiler::csharp::GetClassName
#define GRPC_CUSTOM_CSHARP_GETFILENAMESPACE \
--- a/src/compiler/objective_c_generator.cc
+++ b/src/compiler/objective_c_generator.cc
@@ -22,7 +22,8 @@
#include <set>
#include <sstream>
-#include <google/protobuf/compiler/objectivec/objectivec_helpers.h>
+#include <google/protobuf/compiler/objectivec/helpers.h>
+#include <google/protobuf/compiler/objectivec/names.h>
#include "src/compiler/config.h"
#include "src/compiler/objective_c_generator_helpers.h"
--- a/src/compiler/objective_c_generator_helpers.h
+++ b/src/compiler/objective_c_generator_helpers.h
@@ -21,7 +21,8 @@
#include <map>
-#include <google/protobuf/compiler/objectivec/objectivec_helpers.h>
+#include <google/protobuf/compiler/objectivec/helpers.h>
+#include <google/protobuf/compiler/objectivec/names.h>
#include "src/compiler/config.h"
#include "src/compiler/generator_helpers.h"
--- a/src/compiler/objective_c_plugin.cc
+++ b/src/compiler/objective_c_plugin.cc
@@ -20,7 +20,8 @@
#include <memory>
-#include <google/protobuf/compiler/objectivec/objectivec_helpers.h>
+#include <google/protobuf/compiler/objectivec/helpers.h>
+#include <google/protobuf/compiler/objectivec/names.h>
#include "src/compiler/config.h"
#include "src/compiler/objective_c_generator.h"

View File

@ -0,0 +1,11 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,7 +4,7 @@
include(GNUInstallDirs)
-set(CMAKE_CXX_STANDARD 11)
+set(CMAKE_CXX_STANDARD 14)
find_package(Protobuf REQUIRED)

View File

@ -3,7 +3,7 @@ TERMUX_PKG_DESCRIPTION="osmpbf is a Java/C library to read and write OpenStreetM
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1.5.0
TERMUX_PKG_REVISION=2
TERMUX_PKG_REVISION=3
TERMUX_PKG_SRCURL=https://github.com/openstreetmap/OSM-binary/archive/v${TERMUX_PKG_VERSION}.zip
TERMUX_PKG_SHA256=6738a5684bb68e3f890adda1b4116a6e04df9953d96788192052be53921107cd
TERMUX_PKG_DEPENDS="libc++, libprotobuf"
@ -11,4 +11,6 @@ TERMUX_PKG_GROUPS="science"
termux_step_pre_configure() {
termux_setup_protobuf
CPPFLAGS+=" -DPROTOBUF_USE_DLLS"
}

View File

@ -3,11 +3,11 @@ TERMUX_PKG_DESCRIPTION="Protocol buffers C library"
TERMUX_PKG_LICENSE="BSD 2-Clause"
TERMUX_PKG_MAINTAINER="Henrik Grimler @Grimler91"
TERMUX_PKG_VERSION="1.4.1"
TERMUX_PKG_REVISION=2
TERMUX_PKG_REVISION=3
TERMUX_PKG_SRCURL=https://github.com/protobuf-c/protobuf-c/releases/download/v${TERMUX_PKG_VERSION}/protobuf-c-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=4cc4facd508172f3e0a4d3a8736225d472418aee35b4ad053384b137b220339f
TERMUX_PKG_AUTO_UPDATE=true
TERMUX_PKG_DEPENDS="libc++, libprotobuf, protobuf"
TERMUX_PKG_DEPENDS="abseil-cpp, libc++, libprotobuf, protobuf"
TERMUX_PKG_BREAKS="libprotobuf-c-dev"
TERMUX_PKG_REPLACES="libprotobuf-c-dev"
@ -28,6 +28,17 @@ termux_step_post_get_source() {
}
termux_step_pre_configure() {
find protoc-c -name '*.h' | xargs -n 1 \
sed -i -E 's/GOOGLE_DISALLOW_EVIL_CONSTRUCTORS\(([^)]+)\)/\1(const \1\&) = delete; void operator=(const \1\&) = delete/g'
termux_setup_protobuf
export PROTOC=$(command -v protoc)
CXXFLAGS+=" -std=c++14"
LDFLAGS+=" $($TERMUX_SCRIPTDIR/packages/libprotobuf/interface_link_libraries.sh)"
}
termux_step_post_configure() {
# Avoid overlinking
sed -i 's/ -shared / -Wl,--as-needed\0/g' ./libtool
}

View File

@ -0,0 +1,80 @@
--- a/protoc-c/c_field.cc
+++ b/protoc-c/c_field.cc
@@ -231,7 +231,7 @@
const FieldGenerator& FieldGeneratorMap::get(
const FieldDescriptor* field) const {
- GOOGLE_CHECK_EQ(field->containing_type(), descriptor_);
+ ABSL_CHECK_EQ(field->containing_type(), descriptor_);
return *field_generators_[field->index()];
}
--- a/protoc-c/c_helpers.cc
+++ b/protoc-c/c_helpers.cc
@@ -286,7 +286,7 @@
std::set<std::string> MakeKeywordsMap() {
std::set<std::string> result;
- for (int i = 0; i < GOOGLE_ARRAYSIZE(kKeywordList); i++) {
+ for (int i = 0; i < ABSL_ARRAYSIZE(kKeywordList); i++) {
result.insert(kKeywordList[i]);
}
return result;
@@ -548,7 +548,7 @@
std::unique_ptr<char[]> dest(new char[dest_length]);
const int len = CEscapeInternal(src.data(), src.size(),
dest.get(), dest_length, false);
- GOOGLE_DCHECK_GE(len, 0);
+ ABSL_DCHECK_GE(len, 0);
return std::string(dest.get(), len);
}
--- a/protoc-c/c_message.cc
+++ b/protoc-c/c_message.cc
@@ -499,7 +499,7 @@
// NOTE: not supported by protobuf
vars["maybe_static"] = "";
vars["field_dv_ctype"] = "{ ... }";
- GOOGLE_LOG(DFATAL) << "Messages can't have default values!";
+ ABSL_LOG(ERROR) << "Messages can't have default values!";
break;
case FieldDescriptor::CPPTYPE_STRING:
if (fd->type() == FieldDescriptor::TYPE_BYTES || opt.string_as_bytes())
@@ -521,7 +521,7 @@
break;
}
default:
- GOOGLE_LOG(DFATAL) << "Unknown CPPTYPE";
+ ABSL_LOG(ERROR) << "Unknown CPPTYPE";
break;
}
if (!already_defined)
--- a/protoc-c/c_primitive_field.cc
+++ b/protoc-c/c_primitive_field.cc
@@ -99,7 +99,7 @@
case FieldDescriptor::TYPE_STRING :
case FieldDescriptor::TYPE_BYTES :
case FieldDescriptor::TYPE_GROUP :
- case FieldDescriptor::TYPE_MESSAGE : GOOGLE_LOG(FATAL) << "not a primitive type"; break;
+ case FieldDescriptor::TYPE_MESSAGE : ABSL_LOG(FATAL) << "not a primitive type"; break;
// No default because we want the compiler to complain if any new
// types are added.
@@ -143,7 +143,7 @@
case FieldDescriptor::CPPTYPE_BOOL:
return descriptor_->default_value_bool() ? "1" : "0";
default:
- GOOGLE_LOG(DFATAL) << "unexpected CPPTYPE in c_primitive_field";
+ ABSL_LOG(ERROR) << "unexpected CPPTYPE in c_primitive_field";
return "UNEXPECTED_CPPTYPE";
}
}
@@ -197,7 +197,7 @@
case FieldDescriptor::TYPE_STRING :
case FieldDescriptor::TYPE_BYTES :
case FieldDescriptor::TYPE_GROUP :
- case FieldDescriptor::TYPE_MESSAGE : GOOGLE_LOG(FATAL) << "not a primitive type"; break;
+ case FieldDescriptor::TYPE_MESSAGE : ABSL_LOG(FATAL) << "not a primitive type"; break;
// No default because we want the compiler to complain if any new
// types are added.

View File

@ -3,7 +3,7 @@ TERMUX_PKG_DESCRIPTION="A private, secure, untraceable, decentralised digital cu
TERMUX_PKG_LICENSE="BSD 3-Clause"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=0.18.1.2
TERMUX_PKG_REVISION=1
TERMUX_PKG_REVISION=2
TERMUX_PKG_SRCURL=git+https://github.com/monero-project/monero
TERMUX_PKG_DEPENDS="boost, libc++, libprotobuf, libsodium, libzmq, miniupnpc, openssl, readline, unbound"
TERMUX_PKG_BUILD_DEPENDS="boost-headers"
@ -14,6 +14,7 @@ TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
termux_step_pre_configure() {
termux_setup_protobuf
CPPFLAGS+=" -DPROTOBUF_USE_DLLS"
LDFLAGS+=" -lminiupnpc"
}

View File

@ -0,0 +1,11 @@
--- a/cmake/CheckTrezor.cmake
+++ b/cmake/CheckTrezor.cmake
@@ -103,7 +103,7 @@
"${CMAKE_CURRENT_LIST_DIR}/test-protobuf.cpp"
CMAKE_FLAGS
"-DINCLUDE_DIRECTORIES=${Protobuf_INCLUDE_DIR};${CMAKE_BINARY_DIR}"
- "-DCMAKE_CXX_STANDARD=11"
+ "-DCMAKE_CXX_STANDARD=14"
LINK_LIBRARIES ${Protobuf_LIBRARY}
OUTPUT_VARIABLE OUTPUT
)

View File

@ -3,16 +3,19 @@ TERMUX_PKG_DESCRIPTION="Mobile shell that supports roaming and intelligent local
TERMUX_PKG_LICENSE="GPL-3.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1.4.0
TERMUX_PKG_REVISION=1
TERMUX_PKG_REVISION=2
TERMUX_PKG_SRCURL=https://github.com/mobile-shell/mosh/releases/download/mosh-${TERMUX_PKG_VERSION}/mosh-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=872e4b134e5df29c8933dff12350785054d2fd2839b5ae6b5587b14db1465ddd
TERMUX_PKG_AUTO_UPDATE=true
TERMUX_PKG_UPDATE_VERSION_REGEXP="\d+\.\d+\.\d+"
TERMUX_PKG_DEPENDS="libandroid-support, libc++, libprotobuf, ncurses, openssl, openssh"
TERMUX_PKG_DEPENDS="abseil-cpp, libandroid-support, libc++, libprotobuf, ncurses, openssl, openssh"
TERMUX_PKG_SUGGESTS="mosh-perl"
termux_step_pre_configure() {
termux_setup_protobuf
CXXFLAGS+=" -std=c++14"
LDFLAGS+=" $($TERMUX_SCRIPTDIR/packages/libprotobuf/interface_link_libraries.sh)"
}
termux_step_post_make_install() {

View File

@ -3,10 +3,10 @@ TERMUX_PKG_DESCRIPTION="Open Source Computer Vision Library"
TERMUX_PKG_LICENSE="Apache-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=4.7.0
TERMUX_PKG_REVISION=1
TERMUX_PKG_REVISION=2
TERMUX_PKG_SRCURL=https://github.com/opencv/opencv/archive/${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=8df0079cdbe179748a18d44731af62a245a45ebf5085223dc03133954c662973
TERMUX_PKG_DEPENDS="ffmpeg, libc++, libjpeg-turbo, libopenblas, libpng, libprotobuf, libtiff, libwebp, openjpeg, openjpeg-tools, zlib"
TERMUX_PKG_DEPENDS="abseil-cpp, ffmpeg, libc++, libjpeg-turbo, libopenblas, libpng, libprotobuf, libtiff, libwebp, openjpeg, openjpeg-tools, zlib"
TERMUX_PKG_BUILD_DEPENDS="python-numpy-static"
TERMUX_PKG_PYTHON_COMMON_DEPS="Cython, wheel"
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
@ -15,11 +15,15 @@ TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
-DBUILD_PROTOBUF=OFF
-DPROTOBUF_UPDATE_FILES=ON
-DOPENCV_GENERATE_PKGCONFIG=ON
-DOPENCV_SKIP_CMAKE_CXX_STANDARD=ON
"
termux_step_pre_configure() {
termux_setup_protobuf
CXXFLAGS+=" -std=c++14"
CPPFLAGS+=" -DPROTOBUF_USE_DLLS"
LDFLAGS+=" $($TERMUX_SCRIPTDIR/packages/libprotobuf/interface_link_libraries.sh)"
LDFLAGS+=" -llog"
find "$TERMUX_PKG_SRCDIR" -name CMakeLists.txt -o -name '*.cmake' | \

View File

@ -3,8 +3,9 @@ TERMUX_PKG_DESCRIPTION="A persistent huge storage service, compatible with the v
TERMUX_PKG_LICENSE="BSD 3-Clause"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=3.4.1
TERMUX_PKG_REVISION=1
TERMUX_PKG_SRCURL=git+https://github.com/OpenAtomFoundation/pika
TERMUX_PKG_DEPENDS="google-glog, libc++, libprotobuf, librocksdb"
TERMUX_PKG_DEPENDS="abseil-cpp, google-glog, libc++, libprotobuf, librocksdb"
TERMUX_PKG_BUILD_IN_SRC=true
# ```
@ -24,6 +25,8 @@ termux_step_pre_configure() {
termux_setup_protobuf
CPPFLAGS+=" -D_LIBCPP_ENABLE_CXX17_REMOVED_FEATURES"
CPPFLAGS+=" -DPROTOBUF_USE_DLLS"
LDFLAGS+=" $($TERMUX_SCRIPTDIR/packages/libprotobuf/interface_link_libraries.sh)"
export DISABLE_UPDATE_SB=1
}

View File

@ -5,6 +5,7 @@ TERMUX_PKG_MAINTAINER="@termux"
_TAG_VERSION=13.0.0
_TAG_REVISION=15
TERMUX_PKG_VERSION=${_TAG_VERSION}.${_TAG_REVISION}
TERMUX_PKG_REVISION=1
TERMUX_PKG_SRCURL=(https://android.googlesource.com/platform/system/tools/sysprop
https://android.googlesource.com/platform/system/core
https://android.googlesource.com/platform/system/libbase)

View File

@ -3,6 +3,7 @@ TERMUX_PKG_DESCRIPTION="Server module for Mumble, an open source voice-chat soft
TERMUX_PKG_LICENSE="BSD 3-Clause"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=1.4.287
TERMUX_PKG_REVISION=1
TERMUX_PKG_SRCURL=git+https://github.com/mumble-voip/mumble
TERMUX_PKG_DEPENDS="libc++, libcap, libdns-sd, libprotobuf, openssl-1.1, qt5-qtbase"
TERMUX_PKG_BUILD_DEPENDS="boost, boost-headers, qt5-qtbase-cross-tools"