fix(root/ntfs-3g) symlink of mkfs.ntfs

Signed-off-by: Kevin Williams <admin@utermux.dev>
This commit is contained in:
Kevin Williams 2023-11-19 18:44:05 +08:00 committed by Kevin Williams
parent 56a10565cc
commit d6725be86f
2 changed files with 13 additions and 0 deletions

View File

@ -4,6 +4,7 @@ TERMUX_PKG_LICENSE="GPL-2.0, LGPL-2.0"
TERMUX_PKG_LICENSE_FILE="COPYING, COPYING.LIB"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=2022.10.3
TERMUX_PKG_REVISION=1
TERMUX_PKG_SRCURL=https://github.com/tuxera/ntfs-3g/archive/refs/tags/${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=8bd7749ea9d8534c9f0664d48b576e90b96d45ec8803c9427f6ffaa2f0dde299
TERMUX_PKG_BUILD_DEPENDS="libfuse2, libgcrypt"

View File

@ -12,3 +12,15 @@ diff -uNr ntfs-3g-2022.10.3/src/Makefile.am ntfs-3g-2022.10.3.mod/src/Makefile.a
install-data-local: install-man8
$(LN_S) -f ntfs-3g.8 "$(DESTDIR)$(man8dir)/mount.ntfs-3g.8"
diff -uNr ntfs-3g-2022.10.3/ntfsprogs/Makefile.am ntfs-3g-2022.10.3.mod/ntfsprogs/Makefile.am
--- ntfs-3g-2022.10.3/ntfsprogs/Makefile.am 2022-10-03 17:10:36.000000000 +0800
+++ ntfs-3g-2022.10.3.mod/ntfsprogs/Makefile.am 2023-11-19 18:38:37.711652938 +0800
@@ -166,7 +166,7 @@
if ENABLE_MOUNT_HELPER
install-exec-hook:
$(INSTALL) -d $(DESTDIR)/$(sbindir)
- $(LN_S) -f $(sbindir)/mkntfs $(DESTDIR)$(sbindir)/mkfs.ntfs
+ $(LN_S) -f $(DESTDIR)$(sbindir)/mkntfs $(DESTDIR)$(sbindir)/mkfs.ntfs
install-data-hook:
$(INSTALL) -d $(DESTDIR)$(man8dir)