1
0
mirror of https://github.com/termux/termux-packages synced 2024-06-29 15:57:07 +00:00

kcoreaddons: Use alternative way to remove cache

%ci:no-build
This commit is contained in:
Tee KOBAYASHI 2023-05-01 00:15:04 +09:00 committed by xtkoba
parent ae74986e99
commit d800355bef
2 changed files with 16 additions and 13 deletions

View File

@ -8,16 +8,9 @@ TERMUX_PKG_SHA256=915cd3ac5bb3963fe79a643d70f109a9aa198f97e6a2b5c72f09cd955238da
TERMUX_PKG_DEPENDS="libc++, qt5-qtbase, shared-mime-info"
TERMUX_PKG_BUILD_DEPENDS="extra-cmake-modules, qt5-qtbase-cross-tools, qt5-qttools-cross-tools"
# Keep share/mime/packages/kde5.xml only which would trigger an update after installation
TERMUX_PKG_RM_AFTER_INSTALL="
share/mime/a*
share/mime/font
share/mime/g*
share/mime/i*
share/mime/m*
share/mime/subclasses
share/mime/t*
share/mime/v*
share/mime/x*
share/mime/XMLnamespaces
"
termux_step_post_massage() {
# Check if `update_xdg_mimetypes()` is disabled:
if [ -e "share/mime/mime.cache" ]; then
termux_error_exit "MIME cache found in package. Please disable updating cache."
fi
}

View File

@ -0,0 +1,10 @@
--- a/src/mimetypes/CMakeLists.txt
+++ b/src/mimetypes/CMakeLists.txt
@@ -9,6 +9,6 @@
)
# update XDG mime-types if shared mime info is around
-if(SharedMimeInfo_FOUND)
+if(FALSE)
update_xdg_mimetypes(${KDE_INSTALL_MIMEDIR})
endif()