ghex: Bump to 43.0

This commit is contained in:
Tee KOBAYASHI 2022-11-05 12:53:56 +09:00 committed by xtkoba
parent 7fb026c2ee
commit dc776e5dd0
4 changed files with 97 additions and 4 deletions

View File

@ -2,7 +2,17 @@ TERMUX_PKG_HOMEPAGE=https://wiki.gnome.org/Apps/Ghex
TERMUX_PKG_DESCRIPTION="A simple binary editor for the Gnome desktop."
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=3.41.1
TERMUX_PKG_SRCURL=https://gitlab.gnome.org/GNOME/ghex/-/archive/${TERMUX_PKG_VERSION}/ghex-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=1a003c84d020518c1507b067fd095b96f98cfe8c43af5084c63db5f90702b975
TERMUX_PKG_DEPENDS="atk, gtk3, libiconv, libxml2"
_MAJOR_VERSION=43
TERMUX_PKG_VERSION=${_MAJOR_VERSION}.0
TERMUX_PKG_SRCURL=https://ftp.gnome.org/pub/GNOME/sources/ghex/${_MAJOR_VERSION}/ghex-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_SHA256=866c0622c66fdb5ad2a475e9cfcccb219a1c6431f009acb2291d43f2140b147e
TERMUX_PKG_DEPENDS="glib, gtk4, libadwaita, libcairo, pango"
TERMUX_PKG_BUILD_DEPENDS="g-ir-scanner"
TERMUX_PKG_DISABLE_GIR=false
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
-Dintrospection=enabled
"
termux_step_pre_configure() {
termux_setup_gir
}

View File

@ -0,0 +1,49 @@
<?xml version="1.0"?>
<dump>
<interface name="HexBuffer" get-type="hex_buffer_get_type">
<property name="file" type="GFile" flags="1073742051"/>
</interface>
<class name="HexDocument" get-type="hex_document_get_type" parents="GObject">
<property name="file" type="GFile" flags="1073742051"/>
<property name="buffer" type="HexBuffer" flags="1073742051"/>
<signal name="document-changed" return="void" when="first">
<param type="gpointer"/>
<param type="gboolean"/>
</signal>
<signal name="undo" return="void" when="first">
</signal>
<signal name="redo" return="void" when="first">
</signal>
<signal name="undo-stack-forget" return="void" when="first">
</signal>
<signal name="file-name-changed" return="void" when="first">
</signal>
<signal name="file-saved" return="void" when="first">
</signal>
<signal name="file-read-started" return="void" when="first">
</signal>
<signal name="file-loaded" return="void" when="first">
</signal>
</class>
<boxed name="HexDocumentFindData" get-type="hex_document_find_data_get_type"/>
<boxed name="HexChangeData" get-type="hex_change_data_get_type"/>
<class name="HexWidget" get-type="hex_widget_get_type" parents="GtkWidget,GInitiallyUnowned,GObject">
<implements name="GtkAccessible"/>
<implements name="GtkBuildable"/>
<implements name="GtkConstraintTarget"/>
<property name="document" type="HexDocument" flags="235"/>
<signal name="cursor-moved" return="void" when="first">
</signal>
<signal name="data-changed" return="void" when="first">
</signal>
<signal name="cut-clipboard" return="void" when="first">
</signal>
<signal name="copy-clipboard" return="void" when="first">
</signal>
<signal name="paste-clipboard" return="void" when="first">
</signal>
<signal name="draw-complete" return="void" when="first">
</signal>
</class>
<boxed name="HexWidgetAutoHighlight" get-type="hex_widget_autohighlight_get_type"/>
</dump>

View File

@ -0,0 +1,14 @@
--- a/meson.build
+++ b/meson.build
@@ -169,11 +169,6 @@
subdir('po')
subdir('help')
-gnome.post_install(
- glib_compile_schemas: true,
- gtk_update_icon_cache: true,
- update_desktop_database: true,
-)
### SUMMARY PRINTOUT ###

View File

@ -0,0 +1,20 @@
--- a/src/main.c
+++ b/src/main.c
@@ -124,7 +124,7 @@
}
static void
-open (GApplication *application,
+ghex_open (GApplication *application,
GFile **files,
int n_files,
const char *hint,
@@ -166,7 +166,7 @@
_("GHex - A hex editor for the GNOME desktop"));;
g_signal_connect (app, "activate", G_CALLBACK(activate), NULL);
- g_signal_connect (app, "open", G_CALLBACK(open), NULL);
+ g_signal_connect (app, "open", G_CALLBACK(ghex_open), NULL);
g_signal_connect (app, "handle-local-options",
G_CALLBACK(handle_local_options), NULL);