graphene: Build introspection data

This commit is contained in:
Tee KOBAYASHI 2022-10-22 15:12:59 +09:00 committed by xtkoba
parent 4a33389870
commit defc320c8e
3 changed files with 54 additions and 1 deletions

View File

@ -4,11 +4,33 @@ TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_MAINTAINER="@termux"
_MAJOR_VERSION=1.10
TERMUX_PKG_VERSION=${_MAJOR_VERSION}.8
TERMUX_PKG_REVISION=1
TERMUX_PKG_SRCURL=https://download.gnome.org/sources/graphene/${_MAJOR_VERSION}/graphene-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_SHA256=a37bb0e78a419dcbeaa9c7027bcff52f5ec2367c25ec859da31dfde2928f279a
TERMUX_PKG_DEPENDS="glib"
TERMUX_PKG_BUILD_DEPENDS="g-ir-scanner"
TERMUX_PKG_CONFLICTS="gst-plugins-base (<< 1.20.3-1)"
TERMUX_PKG_BREAKS="gst-plugins-base (<< 1.20.3-1)"
TERMUX_PKG_DISABLE_GIR=false
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
-Dintrospection=disabled
-Dintrospection=enabled
"
termux_step_pre_configure() {
termux_setup_gir
if [ "$TERMUX_ON_DEVICE_BUILD" = "false" ]; then
local pywrap="$TERMUX_PKG_BUILDDIR/_bin/python-wrapper"
mkdir -p "$(dirname "$pywrap")"
cat > "$pywrap" <<-EOF
#!/bin/bash-static
unset LD_LIBRARY_PATH
exec /usr/bin/python3 "\$@"
EOF
chmod 0700 "$pywrap"
echo "Applying wrap-python.diff"
sed -e "s|@PYTHON_WRAPPER@|${pywrap}|g" \
"$TERMUX_PKG_BUILDER_DIR/wrap-python.diff" \
| patch --silent -p1 -d "$TERMUX_PKG_SRCDIR"
fi
}

View File

@ -0,0 +1,20 @@
<?xml version="1.0"?>
<dump>
<boxed name="GraphenePoint" get-type="graphene_point_get_type"/>
<boxed name="GraphenePoint3D" get-type="graphene_point3d_get_type"/>
<boxed name="GrapheneSize" get-type="graphene_size_get_type"/>
<boxed name="GrapheneRect" get-type="graphene_rect_get_type"/>
<boxed name="GrapheneVec2" get-type="graphene_vec2_get_type"/>
<boxed name="GrapheneVec3" get-type="graphene_vec3_get_type"/>
<boxed name="GrapheneVec4" get-type="graphene_vec4_get_type"/>
<boxed name="GrapheneQuad" get-type="graphene_quad_get_type"/>
<boxed name="GrapheneQuaternion" get-type="graphene_quaternion_get_type"/>
<boxed name="GrapheneMatrix" get-type="graphene_matrix_get_type"/>
<boxed name="GraphenePlane" get-type="graphene_plane_get_type"/>
<boxed name="GrapheneFrustum" get-type="graphene_frustum_get_type"/>
<boxed name="GrapheneSphere" get-type="graphene_sphere_get_type"/>
<boxed name="GrapheneBox" get-type="graphene_box_get_type"/>
<boxed name="GrapheneTriangle" get-type="graphene_triangle_get_type"/>
<boxed name="GrapheneEuler" get-type="graphene_euler_get_type"/>
<boxed name="GrapheneRay" get-type="graphene_ray_get_type"/>
</dump>

View File

@ -0,0 +1,11 @@
--- a/src/meson.build
+++ b/src/meson.build
@@ -101,7 +101,7 @@
identfilter_py = join_paths(meson.current_source_dir(), 'identfilter.py')
gir_extra_args = [
- '--identifier-filter-cmd=@0@ @1@'.format(python.full_path(), identfilter_py),
+ '--identifier-filter-cmd=@0@ @1@'.format('@PYTHON_WRAPPER@', identfilter_py),
'--accept-unprefixed',
'--quiet',
'--warn-all',