lite-xl: Bump to 2.1.0

This commit is contained in:
Tee KOBAYASHI 2022-11-20 21:52:46 +09:00 committed by xtkoba
parent 96fde6f6ac
commit e0f6eeb076
2 changed files with 13 additions and 33 deletions

View File

@ -2,20 +2,7 @@ TERMUX_PKG_HOMEPAGE=https://github.com/lite-xl/lite-xl
TERMUX_PKG_DESCRIPTION="A lightweight text editor written in Lua"
TERMUX_PKG_LICENSE="MIT"
TERMUX_PKG_MAINTAINER="@leapofazzam123"
TERMUX_PKG_VERSION=2.0.3
TERMUX_PKG_REVISION=1
TERMUX_PKG_VERSION=2.1.0
TERMUX_PKG_SRCURL="https://github.com/lite-xl/lite-xl/archive/refs/tags/v$TERMUX_PKG_VERSION.tar.gz"
TERMUX_PKG_SHA256=6c8a4ea284f102f772e3aff583236e89d5b1171664526dd501000b681ae5c4e2
TERMUX_PKG_DEPENDS="libc++, sdl2, freetype, liblua52"
termux_step_pre_configure() {
# reproc needs librt but we don't have it
# and we can't directly patch subprojects
# because it needs to be patch after
# meson downloads it
echo 'INPUT(-lc)' > $TERMUX_PREFIX/lib/librt.so
}
termux_step_post_make_install() {
rm $TERMUX_PREFIX/lib/librt.so
}
TERMUX_PKG_SHA256=761d390d0ef2706eeed1c685211d8ff5ce63dacd51d561e56c7e0f7ec0e7ea62
TERMUX_PKG_DEPENDS="freetype, liblua54, pcre2, sdl2"

View File

@ -1,17 +1,10 @@
diff -uNr lite-xl.orig/meson.build lite-xl/meson.build
--- lite-xl.orig/meson.build
+++ lite-xl/meson.build
@@ -47,11 +47,11 @@
libm = cc.find_library('m', required : false)
libdl = cc.find_library('dl', required : false)
threads_dep = dependency('threads')
- lua_dep = dependency('lua5.2', fallback: ['lua', 'lua_dep'],
+ lua_dep = dependency('lua52', fallback: ['lua', 'lua_dep'],
default_options: ['shared=false', 'use_readline=false', 'app=false']
)
pcre2_dep = dependency('libpcre2-8')
- sdl_dep = dependency('sdl2', method: 'config-tool')
+ sdl_dep = dependency('sdl2', method: 'pkg-config')
reproc_dep = dependency('reproc', fallback: ['reproc', 'reproc_dep'],
default_options: [
'default_library=static', 'multithreaded=false',
--- a/meson.build
+++ b/meson.build
@@ -78,6 +78,7 @@
# Lua has no official .pc file
# so distros come up with their own names
lua_names = [
+ 'lua54',
'lua5.4', # Debian
'lua-5.4', # FreeBSD
'lua', # Fedora