ruby: Bump to 3.1.3

This commit is contained in:
Tee KOBAYASHI 2022-11-25 06:54:57 +09:00 committed by xtkoba
parent b3caa2732b
commit f60fb25b1c
5 changed files with 37 additions and 27 deletions

View File

@ -1,23 +1,17 @@
--- ruby-3.1.0/configure
+++ ruby-3.1.0.mod/configure
@@ -9234,13 +9234,19 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
$as_echo "${msg_result_yes}yes${msg_reset}" >&6 ; }
+case ${target_os} in #(
+ *android*) :
+ ;; #(
+ *) :
--- a/configure.ac
+++ b/configure.ac
@@ -510,11 +510,13 @@
]], [[]])],
[
AC_MSG_RESULT(yes)
+ AS_CASE(["$target_os"], [*android*], [], [
target_os=${target_os}-android
+ ;;
+esac
if test "x$cross_compiling" = xno; then :
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for Android API version" >&5
$as_echo_n "checking for Android API version... " >&6; }
+ ])
AS_IF([test "x$cross_compiling" = xno], [
AC_MSG_CHECKING([for Android API version])
# hacky workaround: https://github.com/termux/termux-packages/issues/6176
- rb_android_api=`getprop ro.build.version.sdk`
+ rb_android_api=24
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $rb_android_api" >&5
colorize_result "$rb_android_api" ; }
# RUBY_APPEND_OPTIONS(CPPFLAGS)
AC_MSG_RESULT($rb_android_api)
RUBY_APPEND_OPTIONS(CPPFLAGS, -D__ANDROID_API__=$rb_android_api -Wno-macro-redefined)
])

View File

@ -2,11 +2,11 @@ TERMUX_PKG_HOMEPAGE=https://www.ruby-lang.org/
TERMUX_PKG_DESCRIPTION="Dynamic programming language with a focus on simplicity and productivity"
TERMUX_PKG_LICENSE="BSD 2-Clause"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=3.1.2
TERMUX_PKG_VERSION=3.1.3
TERMUX_PKG_SRCURL=https://cache.ruby-lang.org/pub/ruby/${TERMUX_PKG_VERSION:0:3}/ruby-${TERMUX_PKG_VERSION}.tar.xz
TERMUX_PKG_SHA256=ca10d017f8a1b6d247556622c841fc56b90c03b1803f87198da1e4fd3ec3bf2a
TERMUX_PKG_SHA256=4ee161939826bcdfdafa757cf8e293a7f14e357f62be7144f040335cc8c7371a
# libbffi is used by the fiddle extension module:
TERMUX_PKG_DEPENDS="libandroid-support, libffi, libgmp, readline, openssl, libyaml, zlib"
TERMUX_PKG_DEPENDS="libandroid-execinfo, libandroid-support, libffi, libgmp, readline, openssl, libyaml, zlib"
TERMUX_PKG_RECOMMENDS="clang, make, pkg-config"
TERMUX_PKG_BREAKS="ruby-dev"
TERMUX_PKG_REPLACES="ruby-dev"
@ -27,6 +27,8 @@ termux_step_host_build() {
}
termux_step_pre_configure() {
autoreconf -fi
export PATH=$TERMUX_PKG_HOSTBUILD_DIR/ruby-host/bin:$PATH
if [ "$TERMUX_ARCH_BITS" = 32 ]; then

View File

@ -4,8 +4,8 @@
# Default description for the gem install and update commands.
def install_update_defaults_str
- '--document=ri'
+ '--document=ri --env-shebang'
- "--document=ri"
+ "--document=ri --env-shebang"
end
end

View File

@ -0,0 +1,14 @@
--- a/configure.ac
+++ b/configure.ac
@@ -3112,6 +3112,11 @@
])
])
AS_CASE(["$target_cpu-$target_os"],
+[*-android*], [
+ AC_CHECK_HEADERS([execinfo.h])
+ AS_IF([test "x$ac_cv_header_execinfo_h" = xyes], [
+ AC_CHECK_LIB([android-execinfo], [backtrace])
+ ])],
[*-darwin*], [
AC_CHECK_HEADERS([libproc.h])
AC_CHECK_HEADERS([execinfo.h])

View File

@ -9,10 +9,10 @@
install_dir = with_destdir(gem_dir)
prepare "default gems from #{dir}", gem_dir
RbInstall.no_write do
@@ -1018,7 +1018,7 @@
end
Gem.instance_variable_set(:@ruby, ruby_path) if Gem.ruby != ruby_path
@@ -1010,7 +1010,7 @@
end
install?(:ext, :comm, :gem, :'bundled-gems') do
- gem_dir = Gem.default_dir
+ gem_dir = "@TERMUX_PREFIX@/lib/ruby/gems/3.1.0"
install_dir = with_destdir(gem_dir)