ssss: update to 0.5.7

This commit is contained in:
Leonid Pliushch 2020-12-07 23:09:48 +00:00
parent 1f1fd2c193
commit f994d15f23
No known key found for this signature in database
GPG Key ID: 45F2964132545795
3 changed files with 11 additions and 78 deletions

View File

@ -1,12 +1,11 @@
diff -uNr ssss-0.5/Makefile ssss-0.5.mod/Makefile
--- ssss-0.5/Makefile 2006-01-15 13:10:01.000000000 +0200
+++ ssss-0.5.mod/Makefile 2019-02-13 02:11:26.317857778 +0200
@@ -1,8 +1,7 @@
-all: ssss-split ssss-combine ssss.1 ssss.1.html
+all: ssss-split
diff -uNr ssss-releases-v0.5.7/Makefile ssss-releases-v0.5.7.mod/Makefile
--- ssss-releases-v0.5.7/Makefile 2020-12-07 22:12:51.000000000 +0000
+++ ssss-releases-v0.5.7.mod/Makefile 2020-12-07 23:06:39.473573387 +0000
@@ -5,8 +5,7 @@
doc: ssss.1 ssss.1.html
ssss-split: ssss.c
- $(CC) -W -Wall -O2 -lgmp -o ssss-split ssss.c
- $(CC) -W -Wall -O2 -o ssss-split ssss.c -lgmp
- strip ssss-split
+ $(CC) -W -Wall -DNOMLOCK $(CPPFLAGS) $(CFLAGS) -o ssss-split ssss.c $(LDFLAGS) -lgmp

View File

@ -1,11 +1,10 @@
TERMUX_PKG_HOMEPAGE=http://point-at-infinity.org/ssss/
TERMUX_PKG_HOMEPAGE=https://github.com/MrJoy/ssss
TERMUX_PKG_DESCRIPTION="Simple command-line implementation of Shamir's Secret Sharing Scheme"
TERMUX_PKG_LICENSE="GPL-2.0"
TERMUX_PKG_MAINTAINER="Leonid Pliushch <leonid.pliushch@gmail.com>"
TERMUX_PKG_VERSION=0.5
TERMUX_PKG_REVISION=5
TERMUX_PKG_SRCURL=http://point-at-infinity.org/ssss/ssss-$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_SHA256=5d165555105606b8b08383e697fc48cf849f51d775f1d9a74817f5709db0f995
TERMUX_PKG_VERSION=0.5.7
TERMUX_PKG_SRCURL=https://github.com/MrJoy/ssss/archive/releases/v${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=dbb1f03797cb3fa69594530f9b2c36010f66705b9d5fbbc27293dce72b9c9473
TERMUX_PKG_DEPENDS="libgmp"
TERMUX_PKG_BUILD_IN_SRC=true
@ -13,10 +12,7 @@ termux_step_make_install() {
install -Dm700 ssss-split "$TERMUX_PREFIX"/bin/
ln -sfr "$TERMUX_PREFIX"/bin/ssss-split $TERMUX_PREFIX/bin/ssss-combine
mkdir -p "$TERMUX_PREFIX"/share/man/man1/
install -Dm600 \
"$TERMUX_PKG_BUILDER_DIR"/ssss.1 \
"$TERMUX_PREFIX"/share/man/man1/
install -Dm600 ssss.1 "$TERMUX_PREFIX"/share/man/man1/ssss.1
ln -sfr \
"$TERMUX_PREFIX"/share/man/man1/ssss.1 \
"$TERMUX_PREFIX"/share/man/man1/ssss-combine.1

View File

@ -1,62 +0,0 @@
.TH ssss 1 User Manuals
.SH NAME
ssss \- Split and Combine Secrets using Shamir's Secret Sharing Scheme.
.SH SYNOPSIS
\fBssss-split -t \fIthreshold\fB -n \fIshares\fB [-w \fItoken\fB] [-s \fIlevel\fB] [-x] [-q] [-Q] [-D] [-v]
ssss-combine -t \fIthreshold\fB [-x] [-q] [-Q] [-D] [-v]
\f1
.SH DESCRIPTION
ssss is an implementation of Shamir's Secret Sharing Scheme. The program suite does both: the generation of shares for a known secret, and the reconstruction of a secret using user-provided shares.
.SH COMMANDS
\fBssss-split\f1: prompt the user for a secret and generate a set of corresponding shares.
\fBssss-combine\f1: read in a set of shares and reconstruct the secret.
.SH OPTIONS
.TP
\fB-t \fIthreshold\fB\f1
Specify the number of shares necessary to reconstruct the secret.
.TP
\fB-n \fIshares\fB\f1
Specify the number of shares to be generated.
.TP
\fB-w \fItoken\fB\f1
Text token to name shares in order to avoid confusion in case one utilizes secret sharing to protect several independent secrets. The generated shares are prefixed by these tokens.
.TP
\fB-s \fIlevel\fB\f1
Enforce the scheme's security level (in bits). This option implies an upper bound for the length of the shared secret (shorter secrets are padded). Only multiples of 8 in the range from 8 to 1024 are allowed. If this option is ommitted (or the value given is 0) the security level is chosen automatically depending on the secret's length. The security level directly determines the length of the shares.
.TP
\fB-x\f1
Hex mode: use hexadecimal digits in place of ASCII characters for I/O. This is useful if one wants to protect binary data, like block cipher keys.
.TP
\fB-q\f1
Quiet mode: disable all unnecessary output. Useful in scripts.
.TP
\fB-Q\f1
Extra quiet mode: like \fB-q\f1, but also suppress warnings.
.TP
\fB-D\f1
Disable the diffusion layer added in version 0.2. This option is needed when shares are combined that where generated with ssss version 0.1.
.TP
\fB-v\f1
Print version information.
.SH EXAMPLE
In case you want to protect your login password with a set of ten shares in such a way that any three of them can reconstruct the password, you simply run the command
ssss-split -t 3 -n 10 -w passwd
To reconstruct the password pass three of the generated shares (in any order) to
ssss-combine -t 3
.SH NOTES
To protect a secret larger than 1024 bits a hybrid technique has to be applied: encrypt the secret with a block cipher and apply secret sharing to just the key. Among others openssl and gpg can do the encryption part:
openssl bf -e < file.plain > file.encrypted
gpg -c < file.plain > file.encrypted
.SH SECURITY
\fBssss\f1 tries to lock its virtual address space into RAM for privacy reasons. But this may fail for two reasons: either the current uid doesn't permit page locking, or the RLIMIT_MEMLOCK is set too low. After printing a warning message \fBssss\f1 will run even without obtaining the desired mlock.
.SH AUTHOR
This software (v0.5) was written in 2006 by B. Poettering (ssss AT point-at-infinity.org). Find the newest version of ssss on the project's homepage: \fBhttp://point-at-infinity.org/ssss/\f1.
.SH FURTHER READING
\fBhttp://en.wikipedia.org/wiki/Secret_sharing\f1