new package: php7 (#8339)

This commit is contained in:
xtkoba 2021-12-29 17:56:45 +09:00 committed by GitHub
parent b2fbd905e2
commit fd95b8f912
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
19 changed files with 419 additions and 0 deletions

97
packages/php7/build.sh Normal file
View File

@ -0,0 +1,97 @@
TERMUX_PKG_HOMEPAGE=https://php.net
TERMUX_PKG_DESCRIPTION="Server-side, HTML-embedded scripting language"
TERMUX_PKG_LICENSE="PHP-3.0"
TERMUX_PKG_VERSION=7.4.27
TERMUX_PKG_MAINTAINER="@xtkoba"
TERMUX_PKG_SRCURL=https://github.com/php/php-src/archive/php-${TERMUX_PKG_VERSION}.tar.gz
TERMUX_PKG_SHA256=198c0aae5a4aa56eca5d576e582be9547df3ac8c42e0aa829f3e299843f2bcc3
# Build native php for phar to build (see pear-Makefile.frag.patch):
TERMUX_PKG_HOSTBUILD=true
# Build the native php without xml support as we only need phar:
TERMUX_PKG_EXTRA_HOSTBUILD_CONFIGURE_ARGS="--disable-libxml --disable-dom --disable-simplexml --disable-xml --disable-xmlreader --disable-xmlwriter --without-pear --disable-sqlite3 --without-libxml --without-sqlite3 --without-pdo-sqlite"
TERMUX_PKG_DEPENDS="freetype, libandroid-glob, libandroid-support, libbz2, libcrypt, libcurl, libgd, libgmp, libiconv, liblzma, libsqlite, libxml2, libxslt, libzip, oniguruma, openssl, pcre2, readline, zlib, libicu, libffi, tidy"
TERMUX_PKG_CONFLICTS="php, php-mysql, php-dev"
TERMUX_PKG_RM_AFTER_INSTALL="php/php/fpm"
TERMUX_PKG_SERVICE_SCRIPT=("php-fpm" 'mkdir -p ~/.php\nif [ -f "$HOME/.php/php-fpm.conf" ]; then CONFIG="$HOME/.php/php-fpm.conf"; else CONFIG="$PREFIX/etc/php-fpm.conf"; fi\nexec php-fpm -F -y $CONFIG -c ~/.php/php.ini 2>&1')
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
ac_cv_func_res_nsearch=no
--enable-bcmath
--enable-calendar
--enable-exif
--enable-mbstring
--enable-opcache
--enable-pcntl
--enable-sockets
--mandir=$TERMUX_PREFIX/share/man
--with-bz2=$TERMUX_PREFIX
--with-curl=$TERMUX_PREFIX
--with-openssl=$TERMUX_PREFIX
--with-readline=$TERMUX_PREFIX
--with-iconv-dir=$TERMUX_PREFIX
--with-zlib
--with-pgsql=shared,$TERMUX_PREFIX
--with-pdo-pgsql=shared,$TERMUX_PREFIX
--with-mysqli=mysqlnd
--with-pdo-mysql=mysqlnd
--with-mysql-sock=$TERMUX_PREFIX/tmp/mysqld.sock
--with-apxs2=$TERMUX_PKG_TMPDIR/apxs-wrapper.sh
--with-iconv=$TERMUX_PREFIX
--enable-fpm
--enable-gd
--with-external-gd
--with-external-pcre
--with-zip
--with-xsl
--with-gmp
--with-ffi
--with-tidy=$TERMUX_PREFIX
--enable-intl
--sbindir=$TERMUX_PREFIX/bin
"
termux_step_host_build() {
(cd "$TERMUX_PKG_SRCDIR" && ./buildconf --force)
"$TERMUX_PKG_SRCDIR/configure" ${TERMUX_PKG_EXTRA_HOSTBUILD_CONFIGURE_ARGS}
make -j "$TERMUX_MAKE_PROCESSES"
}
termux_step_pre_configure() {
CPPFLAGS+=" -DGD_FLIP_VERTICAL=1"
CPPFLAGS+=" -DGD_FLIP_HORINZONTAL=2"
CPPFLAGS+=" -DGD_FLIP_BOTH=3"
CPPFLAGS+=" -DU_DEFINE_FALSE_AND_TRUE=1"
LDFLAGS+=" -landroid-glob -llog"
export PATH=$PATH:$TERMUX_PKG_HOSTBUILD_DIR/sapi/cli/
export NATIVE_PHP_EXECUTABLE=$TERMUX_PKG_HOSTBUILD_DIR/sapi/cli/php
if [ "$TERMUX_ARCH" = "aarch64" ]; then
CFLAGS+=" -march=armv8-a+crc"
CXXFLAGS+=" -march=armv8-a+crc"
fi
# Regenerate configure again since we have patched config.m4 files.
./buildconf --force
export EXTENSION_DIR=$TERMUX_PREFIX/lib/php
# Use a wrapper since bin/apxs has the Termux shebang:
echo "perl $TERMUX_PREFIX/bin/apxs \$@" > $TERMUX_PKG_TMPDIR/apxs-wrapper.sh
chmod +x $TERMUX_PKG_TMPDIR/apxs-wrapper.sh
cat $TERMUX_PKG_TMPDIR/apxs-wrapper.sh
}
termux_step_post_configure() {
# Avoid src/ext/gd/gd.c trying to include <X11/xpm.h>:
sed -i 's/#define HAVE_GD_XPM 1//' $TERMUX_PKG_BUILDDIR/main/php_config.h
# Avoid src/ext/standard/dns.c trying to use struct __res_state:
sed -i 's/#define HAVE_RES_NSEARCH 1//' $TERMUX_PKG_BUILDDIR/main/php_config.h
}
termux_step_post_make_install() {
mkdir -p $TERMUX_PREFIX/etc/php-fpm.d
cp sapi/fpm/php-fpm.conf $TERMUX_PREFIX/etc/
cp sapi/fpm/www.conf $TERMUX_PREFIX/etc/php-fpm.d/
sed -i 's/SED=.*/SED=sed/' $TERMUX_PREFIX/bin/phpize
}

View File

@ -0,0 +1,24 @@
diff -u -r ../php-7.3.6/ext/opcache/config.m4 ./ext/opcache/config.m4
--- ../php-7.3.6/ext/opcache/config.m4 2019-05-28 09:33:00.000000000 +0000
+++ ./ext/opcache/config.m4 2019-06-24 20:40:39.725791000 +0000
@@ -145,7 +145,9 @@
}
]])],[dnl
AC_DEFINE(HAVE_SHM_MMAP_ANON, 1, [Define if you have mmap(MAP_ANON) SHM support])
- msg=yes],[msg=no],[msg=no])
+ msg=yes],[msg=no],
+ AC_DEFINE(HAVE_SHM_MMAP_ANON, 1, [Define if you have mmap(MAP_ANON) SHM support])
+ msg=yes)
AC_MSG_RESULT([$msg])
AC_MSG_CHECKING(for mmap() using /dev/zero shared memory support)
@@ -379,6 +381,9 @@
Optimizer/zend_dump.c,
shared,,-DZEND_ENABLE_STATIC_TSRMLS_CACHE=1,,yes)
+ OPCACHE_SHARED_LIBADD=-lpcre2-8
+ PHP_SUBST(OPCACHE_SHARED_LIBADD)
+
PHP_ADD_BUILD_DIR([$ext_builddir/Optimizer], 1)
PHP_ADD_EXTENSION_DEP(opcache, pcre)
fi

View File

@ -0,0 +1,12 @@
diff -u -r ../php-7.2.3/ext/opcache/zend_accelerator_module.c ./ext/opcache/zend_accelerator_module.c
--- ../php-7.2.3/ext/opcache/zend_accelerator_module.c 2018-02-27 16:33:06.000000000 +0000
+++ ./ext/opcache/zend_accelerator_module.c 2018-03-10 23:43:52.824368199 +0000
@@ -308,7 +308,7 @@
STD_PHP_INI_ENTRY("opcache.restrict_api" , "" , PHP_INI_SYSTEM, OnUpdateString, accel_directives.restrict_api, zend_accel_globals, accel_globals)
#ifndef ZEND_WIN32
- STD_PHP_INI_ENTRY("opcache.lockfile_path" , "/tmp" , PHP_INI_SYSTEM, OnUpdateString, accel_directives.lockfile_path, zend_accel_globals, accel_globals)
+ STD_PHP_INI_ENTRY("opcache.lockfile_path" , "@TERMUX_PREFIX@/tmp" , PHP_INI_SYSTEM, OnUpdateString, accel_directives.lockfile_path, zend_accel_globals, accel_globals)
#else
STD_PHP_INI_ENTRY("opcache.mmap_base", NULL, PHP_INI_SYSTEM, OnUpdateString, accel_directives.mmap_base, zend_accel_globals, accel_globals)
#endif

View File

@ -0,0 +1,17 @@
diff -u -r ../php-7.3.3/ext/pdo_pgsql/config.m4 ./ext/pdo_pgsql/config.m4
--- ../php-7.3.3/ext/pdo_pgsql/config.m4 2019-03-05 13:50:40.000000000 +0000
+++ ./ext/pdo_pgsql/config.m4 2019-03-17 22:38:42.906375088 +0000
@@ -14,12 +14,7 @@
PHP_EXPAND_PATH($PGSQL_INCLUDE, PGSQL_INCLUDE)
AC_MSG_CHECKING(for pg_config)
- for i in $PHP_PDO_PGSQL $PHP_PDO_PGSQL/bin /usr/local/pgsql/bin /usr/local/bin /usr/bin ""; do
- if test -x $i/pg_config; then
- PG_CONFIG="$i/pg_config"
- break;
- fi
- done
+ # Avoid picking up cross-compiled pg_config.
if test -n "$PG_CONFIG"; then
AC_MSG_RESULT([$PG_CONFIG])

View File

@ -0,0 +1,29 @@
diff -u -r ../php-7.3.3/ext/pgsql/config.m4 ./ext/pgsql/config.m4
--- ../php-7.3.3/ext/pgsql/config.m4 2019-03-05 13:50:45.000000000 +0000
+++ ./ext/pgsql/config.m4 2019-03-17 22:54:10.391031721 +0000
@@ -8,12 +8,7 @@
PHP_EXPAND_PATH($PGSQL_INCLUDE, PGSQL_INCLUDE)
AC_MSG_CHECKING(for pg_config)
- for i in $PHP_PGSQL $PHP_PGSQL/bin /usr/local/pgsql/bin /usr/local/bin /usr/bin ""; do
- if test -x $i/pg_config; then
- PG_CONFIG="$i/pg_config"
- break;
- fi
- done
+ # Avoid picking up cross-compiled pg_config.
if test -n "$PG_CONFIG"; then
AC_MSG_RESULT([$PG_CONFIG])
@@ -99,6 +94,11 @@
LDFLAGS=$old_LDFLAGS
PHP_ADD_LIBRARY_WITH_PATH(pq, $PGSQL_LIBDIR, PGSQL_SHARED_LIBADD)
+ dnl The pgsql extension uses pcre2 so needs to link explicitly
+ dnl against it to work on android (the php binary, which dlopen():s
+ dnl this module already links to pcre2, but that is not enough on
+ dnl Android, see https://github.com/android-ndk/ndk/issues/201):
+ PHP_ADD_LIBRARY_WITH_PATH(pcre2-8, $PGSQL_LIBDIR, PGSQL_SHARED_LIBADD)
PHP_SUBST(PGSQL_SHARED_LIBADD)
PHP_ADD_INCLUDE($PGSQL_INCLUDE)

View File

@ -0,0 +1,24 @@
--- ./ext/phar/Makefile.frag.orig 2019-12-28 21:58:16.963934498 +0000
+++ ./ext/phar/Makefile.frag 2019-12-28 21:58:32.664200997 +0000
@@ -9,20 +9,7 @@
pharcmd: $(builddir)/phar.php $(builddir)/phar.phar
PHP_PHARCMD_SETTINGS = -n -d 'open_basedir=' -d 'output_buffering=0' -d 'memory_limit=-1' -d phar.readonly=0
-PHP_PHARCMD_EXECUTABLE = ` \
- if test -x "$(top_builddir)/$(SAPI_CLI_PATH)"; then \
- $(top_srcdir)/build/shtool echo -n -- "$(top_builddir)/$(SAPI_CLI_PATH) -n"; \
- if test "x$(PHP_MODULES)" != "x"; then \
- $(top_srcdir)/build/shtool echo -n -- " -d extension_dir=$(top_builddir)/modules"; \
- for i in bz2 zlib phar; do \
- if test -f "$(top_builddir)/modules/$$i.la"; then \
- . $(top_builddir)/modules/$$i.la; $(top_srcdir)/build/shtool echo -n -- " -d extension=$$dlname"; \
- fi; \
- done; \
- fi; \
- else \
- $(top_srcdir)/build/shtool echo -n -- "$(PHP_EXECUTABLE)"; \
- fi;`
+PHP_PHARCMD_EXECUTABLE = $(NATIVE_PHP_EXECUTABLE)
PHP_PHARCMD_BANG = `$(top_srcdir)/build/shtool echo -n -- "$(INSTALL_ROOT)$(bindir)/$(program_prefix)php$(program_suffix)$(EXEEXT)";`
$(builddir)/phar/phar.inc: $(srcdir)/phar/phar.inc

View File

@ -0,0 +1,14 @@
diff -u -r ../php-7.1.0RC3/ext/posix/posix.c ./ext/posix/posix.c
--- ../php-7.1.0RC3/ext/posix/posix.c 2016-09-28 22:15:45.000000000 -0400
+++ ./ext/posix/posix.c 2016-10-03 08:39:39.009354865 -0400
@@ -1163,7 +1163,10 @@
add_assoc_string(return_value, "passwd", pw->pw_passwd);
add_assoc_long (return_value, "uid", pw->pw_uid);
add_assoc_long (return_value, "gid", pw->pw_gid);
+#if !defined(__ANDROID__) || defined(__LP64__)
+ /* Only 64-bit Android has the pw_gecos field. */
add_assoc_string(return_value, "gecos", pw->pw_gecos);
+#endif
add_assoc_string(return_value, "dir", pw->pw_dir);
add_assoc_string(return_value, "shell", pw->pw_shell);
return 1;

View File

@ -0,0 +1,13 @@
diff -u -r ../php-7.3.2/ext/standard/basic_functions.c ./ext/standard/basic_functions.c
--- ../php-7.3.2/ext/standard/basic_functions.c 2019-02-05 13:10:09.000000000 +0000
+++ ./ext/standard/basic_functions.c 2019-02-16 00:28:53.991218270 +0000
@@ -3753,9 +3753,6 @@
PHP_MSHUTDOWN_FUNCTION(basic) /* {{{ */
{
-#ifdef HAVE_SYSLOG_H
- PHP_MSHUTDOWN(syslog)(SHUTDOWN_FUNC_ARGS_PASSTHRU);
-#endif
#ifdef ZTS
ts_free_id(basic_globals_id);
#ifdef PHP_WIN32

View File

@ -0,0 +1,29 @@
diff -u -r ../php-5.6.15/ext/standard/dns.c ./ext/standard/dns.c
--- ../php-5.6.15/ext/standard/dns.c 2015-10-29 05:55:01.000000000 -0400
+++ ./ext/standard/dns.c 2015-11-10 16:05:47.473119979 -0500
@@ -938,7 +938,7 @@
/* Skip QD entries, they're only used by dn_expand later on */
while (qd-- > 0) {
- n = dn_skipname(cp, end);
+ n = __dn_skipname(cp, end);
if (n < 0) {
php_error_docref(NULL TSRMLS_CC, E_WARNING, "Unable to parse DNS data received");
zval_dtor(return_value);
@@ -1049,14 +1049,14 @@
cp = (u_char *)&ans + HFIXEDSZ;
end = (u_char *)&ans +i;
for (qdc = ntohs((unsigned short)hp->qdcount); qdc--; cp += i + QFIXEDSZ) {
- if ((i = dn_skipname(cp, end)) < 0 ) {
+ if ((i = __dn_skipname(cp, end)) < 0 ) {
php_dns_free_handle(handle);
RETURN_FALSE;
}
}
count = ntohs((unsigned short)hp->ancount);
while (--count >= 0 && cp < end) {
- if ((i = dn_skipname(cp, end)) < 0 ) {
+ if ((i = __dn_skipname(cp, end)) < 0 ) {
php_dns_free_handle(handle);
RETURN_FALSE;
}

View File

@ -0,0 +1,14 @@
See https://groups.google.com/a/chromium.org/forum/#!topic/chromium-reviews/AXhZapYuHi8
diff -u -r ../php-5.6.16/ext/standard/php_fopen_wrapper.c ./ext/standard/php_fopen_wrapper.c
--- ../php-5.6.16/ext/standard/php_fopen_wrapper.c 2015-11-25 15:28:38.000000000 -0500
+++ ./ext/standard/php_fopen_wrapper.c 2016-01-04 06:42:57.421589363 -0500
@@ -312,7 +312,7 @@
}
#if HAVE_UNISTD_H
- dtablesize = getdtablesize();
+ dtablesize = sysconf(_SC_OPEN_MAX);
#else
dtablesize = INT_MAX;
#endif

View File

@ -0,0 +1,14 @@
--- ext/standard/proc_open.c.orig 2019-12-28 22:27:36.923774794 +0000
+++ ./ext/standard/proc_open.c 2019-12-28 22:28:31.914719970 +0000
@@ -1048,9 +1048,9 @@
execvp(command, argv);
} else {
if (env.envarray) {
- execle("/bin/sh", "sh", "-c", command, NULL, env.envarray);
+ execle("@TERMUX_PREFIX@/bin/sh", "sh", "-c", command, NULL, env.envarray);
} else {
- execl("/bin/sh", "sh", "-c", command, NULL);
+ execl("@TERMUX_PREFIX@/bin/sh", "sh", "-c", command, NULL);
}
}
_exit(127);

View File

@ -0,0 +1,25 @@
--- ./ext/iconv/config.m4.orig 2019-03-23 10:05:07.289878202 +0000
+++ ./ext/iconv/config.m4 2019-03-23 10:06:27.207978972 +0000
@@ -12,22 +12,6 @@
])
if test "$iconv_avail" != "no"; then
- if test -z "$ICONV_DIR"; then
- for i in /usr/local /usr; do
- if test -f "$i/include/iconv.h" || test -f "$i/include/giconv.h"; then
- PHP_ICONV_PREFIX="$i"
- break
- fi
- done
- if test -z "$PHP_ICONV_PREFIX"; then
- PHP_ICONV_PREFIX="/usr"
- fi
- else
- PHP_ICONV_PREFIX="$ICONV_DIR"
- fi
-
- CFLAGS="-I$PHP_ICONV_PREFIX/include $CFLAGS"
- LDFLAGS="-L$PHP_ICONV_PREFIX/$PHP_LIBDIR $LDFLAGS"
if test -r "$PHP_ICONV_PREFIX/include/giconv.h"; then
PHP_ICONV_H_PATH="$PHP_ICONV_PREFIX/include/giconv.h"

View File

@ -0,0 +1,21 @@
diff -u -r ../php-7.1.0RC3/pear/Makefile.frag ./pear/Makefile.frag
--- ../php-7.1.0RC3/pear/Makefile.frag 2016-09-28 22:15:47.000000000 -0400
+++ ./pear/Makefile.frag 2016-10-03 05:53:02.793555471 -0400
@@ -12,7 +12,7 @@
PEAR_INSTALLER_URL = https://pear.php.net/install-pear-nozlib.phar
install-pear-installer: $(SAPI_CLI_PATH)
- @$(top_builddir)/sapi/cli/php $(PEAR_INSTALL_FLAGS) pear/install-pear-nozlib.phar -d "$(peardir)" -b "$(bindir)" ${PEAR_PREFIX} ${PEAR_SUFFIX}
+ php $(PEAR_INSTALL_FLAGS) pear/install-pear-nozlib.phar -d "$(peardir)" -b "$(bindir)" ${PEAR_PREFIX} ${PEAR_SUFFIX}
install-pear:
@echo "Installing PEAR environment: $(INSTALL_ROOT)$(peardir)/"
@@ -25,7 +25,7 @@
elif test ! -z "$(FETCH)" && test -x "$(FETCH)"; then \
"$(FETCH)" -o $(builddir)/ "${PEAR_INSTALLER_URL}"; \
else \
- $(top_builddir)/sapi/cli/php -n $(srcdir)/fetch.php "${PEAR_INSTALLER_URL}" $(builddir)/install-pear-nozlib.phar; \
+ php -n $(srcdir)/fetch.php "${PEAR_INSTALLER_URL}" $(builddir)/install-pear-nozlib.phar; \
fi \
fi \
fi

View File

@ -0,0 +1,11 @@
--- ./sapi/fpm/www.conf.in
+++ ./sapi/fpm/www.conf.in
@@ -33,7 +33,7 @@
; (IPv6 and IPv4-mapped) on a specific port;
; '/path/to/unix/socket' - to listen on a unix socket.
; Note: This value is mandatory.
-listen = 127.0.0.1:9000
+listen = @TERMUX_PREFIX@/var/run/php-fpm.sock
; Set listen(2) backlog.
; Default Value: 511 (-1 on FreeBSD and OpenBSD)

View File

@ -0,0 +1,3 @@
TERMUX_SUBPKG_DESCRIPTION="Apache 2.0 Handler module for PHP"
TERMUX_SUBPKG_DEPENDS="apache2"
TERMUX_SUBPKG_INCLUDE="libexec/apache2/libphp7.so"

View File

@ -0,0 +1,4 @@
TERMUX_SUBPKG_INCLUDE="bin/php-fpm etc/php-fpm.conf etc/php-fpm.d/www.conf share/man/man8/php-fpm.8.gz var/service/php-fpm"
TERMUX_SUBPKG_CONFFILES="etc/php-fpm.conf etc/php-fpm.d/www.conf"
TERMUX_SUBPKG_DESCRIPTION="FastCGI Process Manager for PHP"
TERMUX_SUBPKG_CONFLICTS="php-fpm"

View File

@ -0,0 +1,4 @@
TERMUX_SUBPKG_INCLUDE="lib/php/pgsql.so lib/php/pdo_pgsql.so"
TERMUX_SUBPKG_DEPENDS="apr-util, postgresql"
TERMUX_SUBPKG_DESCRIPTION="PostgreSQL modules for PHP"
TERMUX_SUBPKG_CONFLICTS="php-pgsql"

View File

@ -0,0 +1,31 @@
diff -uNr php-7.4.1/sapi/apache2handler/config.m4 php-7.4.1.mod/sapi/apache2handler/config.m4
--- php-7.4.1/sapi/apache2handler/config.m4 2019-12-17 18:35:58.000000000 +0200
+++ php-7.4.1.mod/sapi/apache2handler/config.m4 2020-01-02 01:08:05.368395459 +0200
@@ -64,18 +64,9 @@
fi
APXS_LIBEXECDIR='$(INSTALL_ROOT)'`$APXS -q LIBEXECDIR`
- if test -z `$APXS -q SYSCONFDIR`; then
INSTALL_IT="\$(mkinstalldirs) '$APXS_LIBEXECDIR' && \
$APXS -S LIBEXECDIR='$APXS_LIBEXECDIR' \
-i -n php7"
- else
- APXS_SYSCONFDIR='$(INSTALL_ROOT)'`$APXS -q SYSCONFDIR`
- INSTALL_IT="\$(mkinstalldirs) '$APXS_LIBEXECDIR' && \
- \$(mkinstalldirs) '$APXS_SYSCONFDIR' && \
- $APXS -S LIBEXECDIR='$APXS_LIBEXECDIR' \
- -S SYSCONFDIR='$APXS_SYSCONFDIR' \
- -i -a -n php7"
- fi
case $host_alias in
*aix*)
@@ -100,6 +91,8 @@
INSTALL_IT="$INSTALL_IT $SAPI_SHARED"
;;
*)
+ EXTRA_LDFLAGS="`$APR_CONFIG --ldflags --link-ld --libs`"
+ EXTRA_LDFLAGS="`$APU_CONFIG --ldflags --link-ld --libs` $EXTRA_LDFLAGS"
PHP_SELECT_SAPI(apache2handler, shared, mod_php7.c sapi_apache2.c apache_config.c php_functions.c, $APACHE_CFLAGS)
INSTALL_IT="$INSTALL_IT $SAPI_LIBTOOL"
;;

View File

@ -0,0 +1,33 @@
--- sapi/cgi/cgi_main.c.orig 2020-01-19 21:52:00.467616255 +0000
+++ ./sapi/cgi/cgi_main.c 2020-01-19 21:52:20.367984090 +0000
@@ -84,7 +84,7 @@
#include "php_getopt.h"
-#include "fastcgi.h"
+#include "../../main/fastcgi.h"
#if defined(PHP_WIN32) && defined(HAVE_OPENSSL)
# include "openssl/applink.c"
--- ./sapi/fpm/fpm/fpm_log.c.orig 2020-01-19 21:52:34.868252066 +0000
+++ ./sapi/fpm/fpm/fpm_log.c 2020-01-19 21:53:28.639245436 +0000
@@ -16,7 +16,7 @@
#include "fpm_process_ctl.h"
#include "fpm_signals.h"
#include "fpm_scoreboard.h"
-#include "fastcgi.h"
+#include "../../../main/fastcgi.h"
#include "zlog.h"
#ifdef MAX_LINE_LENGTH
--- ./sapi/fpm/fpm/fpm_main.c.orig 2020-01-19 21:54:35.180473976 +0000
+++ ./sapi/fpm/fpm/fpm_main.c 2020-01-19 21:54:47.060693226 +0000
@@ -80,7 +80,7 @@
#include "http_status_codes.h"
-#include "fastcgi.h"
+#include "../../../main/fastcgi.h"
#include <php_config.h>
#include "fpm.h"