1
0
mirror of https://github.com/termux/termux-packages synced 2024-06-23 23:11:39 +00:00
termux-packages/packages/sfeed/Makefile.patch
anon 55c547b287
new package: sfeed -- a scriptable feed aggregator
*tldr*: a shell-script/crontab oriented feed aggregator, parser, and reader

(actively maintained software written in small footpoint C and POSIX shell, project listed on suckless.org/rocks)

------

`sfeed(1)` is a RSS/Atom feed parsing utility written in C
that aimed to be used in a scriptable feed aggregating pipeline
(or newsreading workflow, for a more generally speaking) on UNIX.

`sfeed_update(1)` is the POSIX shell script aimed to be
placed in crontab for periodical updating of feeds,
as the "aggregator".

**NOTE:** Crontab entries is not defined in `build.sh`.
On Termux things in crontab usually read/write to `$PREFIX/var`,
I'd leave this simple task to users for more flexibility
(i.e. I may want to write to homedir or even adaptive storage
instead, with different params.)

(See README and `sfeed_update(1)` source code to get a feel of overall workflow.)

Once the feeds are updated, it will be totally up to user that
how the entires should be handled, for examples:

 - send/sync feed entries to a mailbox using `sendmail(1)`/`isync(1)`, then read entries in Gmail App.
 - read gathered feed entries via TUI using `sfeed_curses(1)`
 - `sfeed_html(1)`, then using something like miniserve to read entries in Web browser.
2022-09-04 17:21:32 +02:00

25 lines
736 B
Diff

diff --git sfeed-1.6.old/Makefile sfeed-1.6/Makefile
index 9958954..3112e11 100644
--- sfeed-1.6.old/Makefile
+++ sfeed-1.6/Makefile
@@ -7,8 +7,8 @@ VERSION = 1.6
SFEED_THEME = mono
# paths
-PREFIX = /usr/local
-MANPREFIX = ${PREFIX}/man
+PREFIX ?= /usr/local
+MANPREFIX ?= ${PREFIX}/share/man
DOCPREFIX = ${PREFIX}/share/doc/${NAME}
RANLIB = ranlib
@@ -16,7 +16,7 @@ RANLIB = ranlib
# use system flags.
SFEED_CFLAGS = ${CFLAGS}
SFEED_LDFLAGS = ${LDFLAGS}
-SFEED_CPPFLAGS = -D_DEFAULT_SOURCE -D_XOPEN_SOURCE=700 -D_BSD_SOURCE
+SFEED_CPPFLAGS = -D_DEFAULT_SOURCE -D_XOPEN_SOURCE=700 -D_BSD_SOURCE ${CPPFLAGS}
# uncomment for conservative locked I/O.
#SFEED_CPPFLAGS = -D_DEFAULT_SOURCE -D_XOPEN_SOURCE=700 -D_BSD_SOURCE \