1
0
mirror of https://github.com/termux/termux-packages synced 2024-06-18 00:27:08 +00:00
termux-packages/packages/busybox/Makefile.patch
Vishal Biswas 160d3aeb06 update ndk to 17 and switch some packages to clang build (#2415)
* update ndk to 17

* bump NDK version in setup-android script

* libnl: fix for ndk r17

* libpixman: use clang's __builtin_shufflevector instead of __builtin_shuffle (#1)

Required to make package build with ndk17.

* fix as for arm

* ndk17 still uses ld.bfd on aarch64

* use -fno-integrated-as for clang only

* glib: remove patch unnecessary after ndk17

* torsocks: remove unneeded patch after ndk17

* subversion: fix build as clang++ now errors out for mismatched flags

* libpulseaudio: fix build with ndk17

https://github.com/termux/termux-packages/pull/2415#issuecomment-388296684

* gst-plugins-good: disable video4linux2

ioctl is defined as __overloadable in ndk17 headers which
  conflicts with v4l2object's member ioctl

* libzmq: disable Werror to build with ndk17

* ltrace: hardcode symbol not available in ndk17

* busybox: build with clang for all arches except arm

* dropbear: build with clang instead of gcc

* gnupg: build with clang instead of gcc

* openssl: use clang for all arches except arm

* picolisp: build with clang instead of gcc

* valgrind: use clang on all arches except aarch64

* Revert "gst-plugins-good: disable video4linux2"

This reverts commit 43850b81cc.
Already applied on base branch.

* libllvm: use default arm triple
2018-05-27 14:55:20 +02:00

17 lines
500 B
Diff

Building with clang causes 'busybox less' to
segfault in INIT_G() on arm, see
https://github.com/termux/termux-packages/issues/1245
diff -u -r ../busybox-1.26.2/Makefile ./Makefile
--- ../busybox-1.26.2/Makefile 2017-01-10 17:01:16.000000000 +0100
+++ ./Makefile 2017-06-27 23:34:15.465534834 +0200
@@ -289,7 +289,7 @@
# Make variables (CC, etc...)
AS = $(CROSS_COMPILE)as
-CC = $(CROSS_COMPILE)gcc
+CC ?= $(CROSS_COMPILE)gcc
LD = $(CC) -nostdlib
CPP = $(CC) -E
AR = $(CROSS_COMPILE)ar