1
0
mirror of https://github.com/termux/termux-packages synced 2024-06-18 02:27:08 +00:00
termux-packages/packages/emscripten/llvm-project-compiler-rt-lib-builtins-CMakeLists.txt.patch.diff
Jia Yuan Lo 4680773baa
upgpkg(main/emscripten): to 3.1.15
Includes:
* chore(main/emscripten): update patches
2022-07-05 09:30:29 +05:30

13 lines
731 B
Diff

diff -uNr llvm-project/compiler-rt/lib/builtins/CMakeLists.txt llvm-project.mod/compiler-rt/lib/builtins/CMakeLists.txt
--- llvm-project/compiler-rt/lib/builtins/CMakeLists.txt 2022-06-20 05:49:00.000000000 +0800
+++ llvm-project.mod/compiler-rt/lib/builtins/CMakeLists.txt 2022-06-28 23:33:05.436005528 +0800
@@ -752,6 +752,8 @@
# Release mode already sets it via -O2/3, Debug mode doesn't.
if (${arch} STREQUAL "armhf")
list(APPEND BUILTIN_CFLAGS_${arch} -fomit-frame-pointer -DCOMPILER_RT_ARMHF_TARGET)
+ elseif(${arch} STREQUAL "arm" AND ANDROID)
+ list(APPEND BUILTIN_CFLAGS_${arch} -fomit-frame-pointer)
endif()
# For RISCV32, we must force enable int128 for compiling long