1
0
mirror of https://github.com/termux/termux-packages synced 2024-06-25 10:47:04 +00:00
termux-packages/packages/bvi/Makefile.in.patch
ElTopo 35aecce3a3 add new package: redir (#772)
* add bvi package

* add new package: cgdb

* add gdb in cgdb's TERMUX_PKG_DEPENDS

* add new package: redir

* bvi package revision 1: fix column number issue with clang (gcc does not seem to have this issue)
bvi (compiled with clang) incorrectly displayed only 12 bytes for each line on a 80-column terminal (instead of 16 bytes normally). command :set cm=## also had similar problems.
I found the issue was caused by the following statements:
       sprintf(addr_form,  "%%0%dllX  ", AnzAdd);
       AnzAdd = sprintf(tmp, addr_form, block_begin);

	   ('block_begin''s data type is off_t)
	   gcc automatically typecasts 'block_begin' from off_t to loff_t,
	   on the otherhand, clang takes address of 'block_begin' and uses
	   it as loff_t thus writes some garbage value in 'tmp' string.
2017-02-20 22:14:52 +01:00

14 lines
530 B
Diff

--- bvi-1.4.0/Makefile.in 2014-10-01 11:59:36.000000000 -0700
+++ src/Makefile.in 2017-02-19 00:34:01.662869384 -0800
@@ -72,8 +72,8 @@
@$(INSTALL_DATA) bmore.help $(helpdir)
@if [ -f $(bindir)/bview ]; then rm $(bindir)/bview; fi
@if [ -f $(bindir)/bvedit ]; then rm $(bindir)/bvedit; fi
- @ln $(bindir)/bvi $(bindir)/bview
- @ln $(bindir)/bvi $(bindir)/bvedit
+ @ln -s $(bindir)/bvi $(bindir)/bview
+ @ln -s $(bindir)/bvi $(bindir)/bvedit
installdirs:
$(SHELL) ${srcdir}/mkinstalldirs $(bindir) $(helpdir) $(man1dir)