1
0
mirror of https://github.com/termux/termux-packages synced 2024-06-20 23:57:08 +00:00
termux-packages/packages/libp8-platform/build-shared-lib.patch
Henrik Grimler cbb644ef79
libp8-platform: build shared library instead of static one
libcec (and perhaps other) looks only for a shared one.
2022-02-07 22:43:42 +01:00

12 lines
583 B
Diff

--- ../CMakeLists.txt.orig 2022-02-07 21:37:34.253637300 +0000
+++ ./CMakeLists.txt 2022-02-07 21:37:47.633618078 +0000
@@ -36,7 +36,7 @@
set(SOURCES src/util/StringUtils.cpp)
-add_library(p8-platform ${SOURCES} ${PLAT_SOURCES})
+add_library(p8-platform SHARED ${SOURCES} ${PLAT_SOURCES})
target_link_libraries(p8-platform ${p8-platform_LIBRARIES})
set_target_properties(p8-platform PROPERTIES VERSION ${p8-platform_VERSION_MAJOR}.${p8-platform_VERSION_MINOR}.${p8-platform_VERSION_PATCH}
SOVERSION ${p8-platform_VERSION_MAJOR})