termux-packages/packages/starship/0001-Cargo.toml.patch

23 lines
667 B
Diff

--- a/Cargo.toml
+++ b/Cargo.toml
@@ -29,8 +29,7 @@
"""
[features]
-default = ["battery", "notify", "git-repository-max-perf"]
-battery = ["starship-battery"]
+default = ["notify", "git-repository-max-perf"]
config-schema = ["schemars"]
notify = ["notify-rust"]
@@ -74,9 +73,6 @@
serde_json = "1.0.89"
sha1 = "0.10.5"
shadow-rs = { version = "0.18.0", default-features = false }
-# battery is optional (on by default) because the crate doesn't currently build for Termux
-# see: https://github.com/svartalf/rust-battery/issues/33
-starship-battery = { version = "0.7.9", optional = true }
strsim = "0.10.0"
systemstat = "=0.2.2"
terminal_size = "0.2.3"