termux-packages/packages/qemu-system-x86-64-headless/0011-misc-build-fixes.patch

46 lines
1.4 KiB
Diff

diff -uNr qemu-5.2.0/include/qapi/util.h qemu-5.2.0.mod/include/qapi/util.h
--- qemu-5.2.0/include/qapi/util.h 2020-12-08 18:59:44.000000000 +0200
+++ qemu-5.2.0.mod/include/qapi/util.h 2020-12-09 17:15:41.400859913 +0200
@@ -11,6 +11,10 @@
#ifndef QAPI_UTIL_H
#define QAPI_UTIL_H
+#include <glib.h>
+
+typedef struct Error Error;
+
typedef struct QEnumLookup {
const char *const *array;
int size;
--- a/meson.build
+++ b/meson.build
@@ -201,7 +201,7 @@
# Specify linker-script with add_project_link_arguments so that it is not placed
# within a linker --start-group/--end-group pair
-if get_option('fuzzing')
+if false
add_project_link_arguments(['-Wl,-T,',
(meson.current_source_dir() / 'tests/qtest/fuzz/fork_fuzz.ld')],
native: false, language: ['c', 'cpp', 'objc'])
@@ -1575,8 +1575,8 @@
specific_ss.add_all(when: 'CONFIG_LINUX_USER', if_true: linux_user_ss)
# needed for fuzzing binaries
-subdir('tests/qtest/libqos')
-subdir('tests/qtest/fuzz')
+#subdir('tests/qtest/libqos')
+#subdir('tests/qtest/fuzz')
########################
# Library dependencies #
diff -uNr qemu-5.2.0/tests/meson.build qemu-5.2.0.mod/tests/meson.build
--- qemu-5.2.0/tests/meson.build 2020-12-08 18:59:44.000000000 +0200
+++ qemu-5.2.0.mod/tests/meson.build 2020-12-09 17:24:07.616614694 +0200
@@ -286,5 +286,4 @@
endif
subdir('qapi-schema')
-subdir('qtest')
subdir('migration')