1
0
mirror of https://github.com/termux/termux-packages synced 2024-06-25 16:37:08 +00:00
termux-packages/packages/brotli/CMakeLists.txt.patch
Fredrik Fornwall d8b43f2e48 brotli: Update from 1.0.3 to 1.0.4
Also switch to building with cmake, and add a patch to build the
brotli binary against shared libs (binary size from 700 kb to 70 kb).
2018-05-27 14:51:20 +02:00

13 lines
436 B
Diff

diff -u -r ../brotli-1.0.4/CMakeLists.txt ./CMakeLists.txt
--- ../brotli-1.0.4/CMakeLists.txt 2018-03-29 08:37:07.000000000 +0000
+++ ./CMakeLists.txt 2018-05-27 12:33:42.384489726 +0000
@@ -183,7 +183,7 @@
# Build the brotli executable
add_executable(brotli ${BROTLI_CLI_C})
-target_link_libraries(brotli ${BROTLI_LIBRARIES_STATIC})
+target_link_libraries(brotli ${BROTLI_LIBRARIES})
# Installation
if(NOT BROTLI_BUNDLED_MODE)