termux-packages/packages/k2pdfopt/0001-CMakeLists.txt-bugs.patch

33 lines
872 B
Diff

From 211773bee7fbdbe5aa526af2319d11b435157076 Mon Sep 17 00:00:00 2001
From: yangfl <yangfl@users.noreply.github.com>
Date: Mon, 7 Jan 2019 16:47:43 +0800
Subject: [PATCH 01/10] CMakeLists.txt: bugs
---
CMakeLists.txt | 2 ++
1 file changed, 2 insertions(+)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e218279..985d098 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -122,6 +122,7 @@ configure_file (
"${PROJECT_SOURCE_DIR}/config.h.in"
"${PROJECT_BINARY_DIR}/config.h"
)
+include_directories(${PROJECT_BINARY_DIR})
add_subdirectory(willuslib)
add_subdirectory(k2pdfoptlib)
@@ -130,6 +131,7 @@ add_subdirectory(k2pdfoptlib)
add_executable(k2pdfopt k2pdfopt.c)
target_link_libraries (k2pdfopt k2pdfoptlib willuslib ${K2PDFOPT_LIB} pthread)
+install(TARGETS k2pdfopt RUNTIME DESTINATION bin)
message("")
message("-- Summary --")
--
2.28.0