1
0
mirror of https://github.com/termux/termux-packages synced 2024-06-13 09:26:39 +00:00
termux-packages/packages/ghc-libs/fix-target-elf-check.patch
Aditya Alok 80f7a2a0df refactor(ghc-libs): rename ghc to ghc-libs
- seperate ghc libraries from ghc bins
- enable dynamic libs for ghc
  * ghc-libs is further seperated into static and dynamic packages
  * enabling dynamic support will reduce package size as well as there
    performance  on device.

closes #5973

Signed-off-by: Aditya Alok <dev.aditya.alok@gmail.com>
2022-03-09 10:01:57 +09:00

12 lines
468 B
Diff

--- ghc-8.10.7/mk/config.mk.in 2021-06-21 12:24:36.000000000 +0530
+++ ghc-8.10.7-patch/mk/config.mk.in 2022-02-04 13:18:15.667333665 +0530
@@ -105,7 +105,7 @@
WITH_TERMINFO=YES
endif
-ifeq "$(findstring $(TargetOS_CPP),linux freebsd dragonfly openbsd netbsd solaris2 kfreebsdgnu haiku linux-android)" ""
+ifeq "$(findstring $(TargetOS_CPP),linux freebsd dragonfly openbsd netbsd solaris2 kfreebsdgnu haiku linux_android)" ""
TargetElf = NO
else
TargetElf = YES