tree-wide: Cleanup lib{pthread,rt} patches

not handled in cec1d690cf or before.

%ci:no-build
This commit is contained in:
Tee KOBAYASHI 2023-02-13 18:50:48 +09:00 committed by xtkoba
parent bca8c96bf5
commit 129e18a38c
11 changed files with 0 additions and 123 deletions

View File

@ -1,11 +0,0 @@
diff -uNr boinctui-2.5.0/configure.in boinctui-2.5.0.mod/configure.in
--- boinctui-2.5.0/configure.in 2016-09-10 20:01:45.000000000 +0300
+++ boinctui-2.5.0.mod/configure.in 2020-03-26 15:21:40.598627902 +0200
@@ -39,7 +39,6 @@
)
AC_CHECK_LIB(expat, main, , [AC_MSG_ERROR([Couldn't find expat library])] )
-AC_CHECK_LIB(pthread, main, , [AC_MSG_ERROR([Couldn't find pthread library])] )
AC_ARG_WITH(
[gnutls],

View File

@ -17,13 +17,3 @@
dnl The directories with content.
dnl Documentation.
@@ -747,8 +737,7 @@
fi
])
-AC_CHECK_LIB(pthread, pthread_setname_np, [
- AC_DEFINE([HAVE_PTHREAD_SETNAME_NP],[1],[Enable pthread_setname_np])])
+ AC_DEFINE([HAVE_PTHREAD_SETNAME_NP],[1],[Enable pthread_setname_np])
AS_IF([test "x$enable_libdebuginfod" = "xyes" || test "x$enable_libdebuginfod" = "xdummy"],
[AC_DEFINE([ENABLE_LIBDEBUGINFOD], [1], [Enable libdebuginfod])])

View File

@ -1,12 +0,0 @@
--- a/configure.ac
+++ b/configure.ac
@@ -76,7 +76,7 @@
*)
AC_MSG_RESULT([${host_os}])
AX_PTHREAD([], [AC_MSG_ERROR([pthread is required to build $PACKAGE_NAME])])
- AC_CHECK_LIB(pthread, [pthread_once], [], [AC_MSG_ERROR([pthread with pthread_once required to build $PACKAGE_NAME])])
+ AC_CHECK_LIB(pthread, [pthread_once], [], [AC_MSG_NOTICE([pthread with pthread_once required to build $PACKAGE_NAME])])
;;
esac
AM_CONDITIONAL(WIN32, test x$win32 = xtrue)

View File

@ -1,11 +0,0 @@
--- a/configure.ac
+++ b/configure.ac
@@ -107,7 +107,7 @@
AC_C_BIGENDIAN
-AC_CHECK_LIB(pthread, pthread_create, ,
+AC_CHECK_LIB(c, pthread_create, ,
AC_MSG_ERROR([Could not find pthread library - please install libpthread]))
AC_CHECK_LIB(m, sqrt, ,
AC_MSG_ERROR([Could not find math library - please install libm]))

View File

@ -1,22 +0,0 @@
--- a/configure.ac
+++ b/configure.ac
@@ -522,7 +522,7 @@
[enable_posix_threads=no],
[enable_posix_threads=yes])
if test x$enable_posix_threads != xno; then
- AC_CHECK_LIB(pthread, pthread_create, [HAVE_PTHREAD=yes], [HAVE_PTHREAD=no])
+ AC_CHECK_LIB(c, pthread_create, [HAVE_PTHREAD=yes], [HAVE_PTHREAD=no])
else
HAVE_PTHREAD=no
fi
--- a/sdk/configure.ac
+++ b/sdk/configure.ac
@@ -244,7 +244,7 @@
[enable_posix_threads=no],
[enable_posix_threads=yes])
if test x$enable_posix_threads != xno; then
- AC_CHECK_LIB(pthread, pthread_create, [HAVE_PTHREAD=yes], [HAVE_PTHREAD=no])
+ AC_CHECK_LIB(c, pthread_create, [HAVE_PTHREAD=yes], [HAVE_PTHREAD=no])
else
HAVE_PTHREAD=no
fi

View File

@ -1,10 +0,0 @@
--- a/configure.ac
+++ b/configure.ac
@@ -52,7 +52,6 @@
AC_CHECK_LIB([intl], [libintl_dgettext]) # needed to statically link libparted, but not given in its pkgconfig file
AC_CHECK_LIB([uuid], [uuid_generate]) # needed to statically link libparted, but not given in its pkgconfig file
PKG_CHECK_MODULES([PARTED], [libparted])
-AC_CHECK_LIB([pthread], [main], ,[AC_MSG_ERROR([pthread development library not found])])
# Checks for header files.
AC_CHECK_HEADERS([fcntl.h inttypes.h netinet/in.h stddef.h stdint.h stdlib.h string.h sys/file.h sys/ioctl.h unistd.h])

View File

@ -1,14 +1,5 @@
--- ../seafile/configure.ac 2018-04-28 11:32:08.357388789 +0200
+++ ./configure.ac 2018-04-28 11:33:03.093385829 +0200
@@ -75,7 +75,7 @@
fi
fi
-AC_CHECK_LIB(pthread, pthread_create, [echo "found library pthread"], AC_MSG_ERROR([*** Unable to find pthread library]), )
+#AC_CHECK_LIB(pthread, pthread_create, [echo "found library pthread"], AC_MSG_ERROR([*** Unable to find pthread library]), )
AC_CHECK_LIB(sqlite3, sqlite3_open,[echo "found library sqlite3"] , AC_MSG_ERROR([*** Unable to find sqlite3 library]), )
dnl Do we need to use AX_LIB_SQLITE3 to check sqlite?
@@ -134,6 +134,8 @@
LIB_CRYPT32=
fi

View File

@ -1,14 +1,5 @@
--- a/meson.build
+++ b/meson.build
@@ -58,8 +58,6 @@
else
has_dmabuf = false
endif
-pthreads = dependency('threads')
-rt = cc.find_library('rt')
# XXX dtrace -G (Solaris, FreeBSD, NetBSD) isn't supported yet
is_linux = host_machine.system() == 'linux'
is_darwin = host_machine.system() == 'darwin'
@@ -92,7 +90,6 @@
subdir('protocols')

View File

@ -1,10 +0,0 @@
--- a/src/ct/CMakeLists.txt
+++ b/src/ct/CMakeLists.txt
@@ -93,7 +93,6 @@
${CURL_LIBRARIES}
${UCHARDET_LIBRARIES}
${FRIBIDI_LIBRARIES}
- pthread
7za_static
)
if(USE_SHARED_FMT_SPDLOG)

View File

@ -1,11 +0,0 @@
--- a/configure.ac
+++ b/configure.ac
@@ -93,7 +93,7 @@
AC_CHECK_LIB([ogg],[ogg_stream_init],,AC_MSG_ERROR([Can't find libogg]))
AC_CHECK_LIB([theora],[theora_encode_YUVin],,
AC_MSG_ERROR([Can't find libtheora]))
-AC_CHECK_LIB([pthread],[pthread_mutex_lock],,
+AC_CHECK_LIB([c],[pthread_mutex_lock],,
AC_MSG_ERROR([Can't find libpthread]))
if test x$jack = xtrue ; then

View File

@ -20,11 +20,3 @@
INSTALL=install
PROGS+= temu$(EXE)
@@ -72,7 +72,6 @@
ifndef CONFIG_WIN32
EMU_OBJS+=fs_disk.o
-EMU_LIBS=-lrt
endif
ifdef CONFIG_FS_NET
CFLAGS+=-DCONFIG_FS_NET