graphviz: Bump to 5.0.1

Use Autotools, partially reverting 290ae05f35.
This commit is contained in:
Tee KOBAYASHI 2022-09-16 03:08:48 +09:00 committed by xtkoba
parent 8a489238b5
commit 1b126e9572
2 changed files with 31 additions and 40 deletions

View File

@ -1,30 +0,0 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f8e9583..b025115 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -126,10 +126,8 @@ if(with_zlib)
find_package(ZLIB)
endif()
-if(UNIX)
- find_library(MATH_LIB m)
- link_libraries(${MATH_LIB})
-endif()
+set(MATH_LIB -lm)
+link_libraries(${MATH_LIB})
if(WIN32)
# Find Windows specific dependencies
diff --git a/lib/gvc/CMakeLists.txt b/lib/gvc/CMakeLists.txt
index b437bde..34ebade 100644
--- a/lib/gvc/CMakeLists.txt
+++ b/lib/gvc/CMakeLists.txt
@@ -75,6 +75,8 @@ if(ZLIB_FOUND)
target_link_libraries(gvc PUBLIC ${ZLIB_LIBRARIES})
endif()
+target_link_libraries(gvc PUBLIC -landroid-glob)
+
if(${with_ortho})
target_link_libraries(gvc PRIVATE
$<TARGET_OBJECTS:ortho_obj>

View File

@ -2,23 +2,44 @@ TERMUX_PKG_HOMEPAGE=https://www.graphviz.org/
TERMUX_PKG_DESCRIPTION="Rich set of graph drawing tools"
TERMUX_PKG_LICENSE="EPL-2.0"
TERMUX_PKG_MAINTAINER="@termux"
TERMUX_PKG_VERSION=5.0.0
#TERMUX_PKG_REVISION=1
TERMUX_PKG_VERSION=5.0.1
TERMUX_PKG_SRCURL=https://gitlab.com/graphviz/graphviz/-/archive/$TERMUX_PKG_VERSION/graphviz-$TERMUX_PKG_VERSION.tar.gz
TERMUX_PKG_SHA256=f8cc576694ae93659f453b6b4a4c2f04572a90cfccdca2d4271f2e7c60bb3d60
TERMUX_PKG_SHA256=6c704a3ffeaf2f7ae63f7d0da453cd624d93a9306a2e5dbda07e5ec38343d2b8
TERMUX_PKG_DEPENDS="libandroid-glob, libc++, libcairo, pango, libexpat, libltdl, librsvg, libgd, zlib"
TERMUX_PKG_BREAKS="graphviz-dev"
TERMUX_PKG_REPLACES="graphviz-dev"
TERMUX_PKG_BUILD_DEPENDS="libtool"
TERMUX_PKG_FORCE_CMAKE=true
TERMUX_PKG_EXTRA_CONFIGURE_ARGS="
--enable-guile=no
--enable-java=no
--enable-lua=no
--enable-ocaml=no
--enable-perl=no
--enable-php=no
--enable-python=no
--enable-r=no
--enable-ruby=no
--enable-sharp=no
--enable-swig=no
--enable-tcl=no
--with-expatlibdir=$TERMUX_PREFIX/lib
--with-ltdl-include=$TERMUX_PREFIX/include
--with-ltdl-lib=$TERMUX_PREFIX/lib
--with-pangocairo=yes
--with-pic
--with-poppler=no
--with-x=no
"
TERMUX_PKG_FORCE_CMAKE=false
TERMUX_PKG_RM_AFTER_INSTALL="bin/*-config share/man/man1/*-config.1"
termux_step_post_make_install() {
# Some binaries (dot_builtins, gvpack) links against these:
cd $TERMUX_PREFIX/lib
for lib in graphviz/*.so*; do
ln -s -f $lib $(basename $lib)
done
termux_step_pre_configure() {
./autogen.sh NOCONFIG
export HOSTCC="gcc"
LDFLAGS+=" -lm -landroid-glob"
LDFLAGS+=" $($CC -print-libgcc-file-name)"
LDFLAGS+=" -Wl,-rpath=$TERMUX_PREFIX/lib/graphviz"
}
termux_step_create_debscripts() {