1
0
mirror of https://github.com/termux/termux-packages synced 2024-06-20 00:07:05 +00:00
termux-packages/packages/svt-av1/no-libpthread.patch
2023-01-03 00:34:07 +00:00

43 lines
942 B
Diff

--- a/Source/App/DecApp/CMakeLists.txt
+++ b/Source/App/DecApp/CMakeLists.txt
@@ -30,7 +30,6 @@
if(UNIX)
target_link_libraries(SvtAv1DecApp
- pthread
m)
endif()
--- a/Source/App/EncApp/CMakeLists.txt
+++ b/Source/App/EncApp/CMakeLists.txt
@@ -33,7 +33,6 @@
SvtAv1Enc)
if(UNIX)
target_link_libraries(SvtAv1EncApp
- pthread
m)
endif()
--- a/Source/Lib/Decoder/CMakeLists.txt
+++ b/Source/Lib/Decoder/CMakeLists.txt
@@ -24,7 +24,7 @@
endif()
list(APPEND PLATFORM_LIBS Threads::Threads)
endif()
- set(LIBS_PRIVATE "-lpthread -lm")
+ set(LIBS_PRIVATE "-lm")
endif()
if(COVERAGE)
--- a/Source/Lib/Encoder/CMakeLists.txt
+++ b/Source/Lib/Encoder/CMakeLists.txt
@@ -25,7 +25,7 @@
endif()
list(APPEND PLATFORM_LIBS Threads::Threads)
endif()
- set(LIBS_PRIVATE "-lpthread -lm")
+ set(LIBS_PRIVATE "-lm")
endif()
if(COVERAGE)